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1 Introduction

The Aladin software is an interactive atlas of the sky. It allows users to view digitised images of the 
sky and superimpose information from catalogues or astronomical databases. 

Aladin is distributed in two forms: a lighter version "Aladin Lite" for web browsers, and a more 
complete version "Aladin Desktop" for classic desktop use. This manual concerns Aladin Desktop 
only.

Aladin Desktop allows you to access interactively most of the image data and astronomical cata-
logues provided by major agencies, data centres, institutes and local projects, including Simbad/
CDS, NED/NASA, VizieR/CDS, MAST/STScI/NASA, CADC, SkyView/HEASARC/NASA, 
ESAC/ESA, JAXA, SDSS/SLOAN, SkyBot/IMCCE, i.e. all the data available in the so-called "Vir-
tual Observatory".
 
Aladin is a software dedicated to astronomy professionals. It can also be used by teachers, students 
and amateurs. It is free of charge, and the holder of the rights is the University of Strasbourg/CNRS 
(see legal notice). It has been translated into several languages including English, French, Italian, 
German, Iranian, Russian, Chinese, Japanese, Spanish, ...

Aladin is commonly used for:
➢ Visualisation and verification of image and catalogue data;
➢ Exploration of available astronomical data;
➢ The preparation of observation missions;
➢ The generation of field maps.

Aladin is developed by the Strasbourg Astronomical Data Center (CDS). It is compatible with most 
desktop computer configurations including Windows, Linux and Mac. It does not require significant
computing resources unless it has to handle very large catalogues (several hundred thousand ob-
jects).

Created in 1999, Aladin supports the standards of the International Virtual Observatory alliance 
(IVOA) (or "Virtual Observatory"), it is interconnectable with other visualisation and analysis tools 
(TOPcat, CASSIS, DS9, SPLAT, ...). All these strong points make it a powerful tool for data explor-
ation and integration.

Aladin's website address is http://aladin.cds.unistra.fr.
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2 Installation

The method of installing Aladin depends on your hardware configuration. In any case, it will only
take a few seconds.

Installation

Aladin requires only a few megabytes of disk space for installation and 256 megabytes of RAM is
sufficient for most jobs.

Any system

URL: http://aladin.cds.unistra.fr/java/nph-aladin.pl

This URL uses WebStart technology specific to software written in Java. If you already have Java
installed1, a simple click on this URL will install and launch the application.

Technical note: Depending on your security system, you may have to save the launch file (extension
" Aladin.jnlp "), then explicitly indicate (generally via a right-click contextual menu2) that you want
to open this file with " Java Web start ".

Specific alternatives for each Operating System

Windows   

URL: http://aladin.cds.unistra.fr/java/Aladin.exe

If  you  are  working  under  Windows,  the  fastest  and  easiest  method  is  to  simply  copy  the
"Aladin.exe" file into one of your folders, or even on your desktop. That's all you have to do! Or ...
it is not impossible that you will have to convince your anti-virus software that Aladin is not a virus.

Mac   

URL: http://aladin.cds.unistra.fr/java/Aladin.dmg

The installation on Macintosh is in the form of a classic "dmg" package. You download it, open it,
and copy the "Aladin.app" file to your "Application" folder. That's it! Or ... you will probably need
to allow Aladin to run in the security centre of your Mac. A quick tour of your favourite search
engine will give you the solution for your specific system.

1 http://www.java.com  
2 In the case of a Mac, it may be necessary to hold down the Ctrl key to see the start button appear.
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Linux   and other Unix systems   

URL: http://aladin.cds.unistra.fr/java/Aladin.tar

The installation under Linux is presented as a "tar" archive file. You download the file, you unzip
the files using the command "tar xvf Aladin.tar" or any other equivalent utility. That's it!

Note:  Aladin can be used on locally  stored data.  However,  it  is  preferable to  have an Internet
connection, even a low-speed one (≥ 200Ko/s) to be able to access astronomical databases as well. 

For more details on the installation of Aladin or to access the latest version under test, please refer
to the following web page:

http://aladin.cds.unistra.fr/java/nph-aladin.pl?frame=downloading
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3 Getting started
To give you a brief overview of Aladin's potential, here is a typical scenario for viewing image and
catalogue data around an astronomical object:

1. Launch of Aladin
2. Searching for an astronomical image of the M51 object
3. Search for Simbad data around this object
4. Loading of the Gaia catalogue around this object
5. Data visualization (moving, zooming...)
6. Consultation of measurements and original data
7. Backup

We will follow this scenario step by step.

Launch of Aladin (1)

Launching Aladin depends on the type of hardware configuration you have. Under Windows and
Macintosh, a double-click on the Aladin icon will launch the application. Under Linux and other
Unix stations, you need to  place the following command: Aladin

Data loading (2, 3 and 4)

The easiest way to load an image of an astronomical object into Aladin is to click in the central
panel to load a sky background - by default the colour DSS - and then enter the name or position of
the  central  object  in  the  input  field  labelled  'Command'.  In  our
example, it is "M51". 
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To choose a sky background other than the default one, it is necessary to
open the Data Discovery Tree which is visible on the left of the Aladin
window,  then  double-click  on  the  desired  sky  background.  In  the
example opposite, GALEX GR6/7 in colour. In the same way, you can
load Simbad data from the "Data base" branch and the Gaia catalogue
from the  "Catalog/VizieR/I-Astrometrical  Data/Gaia  DR3.../Gaia  DR3
Source..." branch. Due to the large number of collections described in the
tree, it is often more convenient to simply enter a keyword in the "select"
field below the tree -  for example "Gaia" -  to keep only the relevant
collections in the tree. 

Each time you select a collection in the tree, a window appears next to it
offering  the  different  possible  access  modes.  Double-clicking  on  the
name of the collection in the tree is a shortcut to use the default access

mode. In our example, "in view" means that the data will only be loaded on the current view field.

Data visualization (4) 

Data visualization is done in Aladin's main window. 
It is mainly composed of 4 elements:

1. The  collections  tree  ("Data
tree"):  displays all available data
collections  (>20,000  collections
of images, cubes, catalogues). 

2. Stack: presents all the data loaded
in the form of a stack of "plans.
The observer's eye is at the top of
the  stack  and  will  see
"transparently"  all  the  activated
plans.

3. The View: displays the portion of
the image visible according to the
stack  plans  and  the  zoom  and
superimposes  on  this  image
graphic  symbols  corresponding  to  the  astronomical  objects  in  the  loaded  tables  and
catalogues.

4. Measures: displays the parameters of the astronomical objects selected in the view with the
mouse (magnitude, parallax...). 

Activation  of  a  plan:  The activation  or  deactivation  of  a
plan is  done by clicking on the logo of each plan in  the
stack. It is also possible to change the transparency of these
plans  by means of  the small  ruler  at  the bottom of each
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logo. Finally, by swapping plans with the mouse (click/drag/drop) you can change the foreground to
make the view easier to read. 

Zoom adjustment:     The most immediate way to adjust the zoom factor is to use the mouse  scroll
wheel with the mouse pointer positioned "in view". If you don't have a scroll wheel mouse, you can
use the ruler just below the stack.

Centering  on  a  particular  object:  The  centre  of  the  view  shows  a
crosshairs (a small magenta cross). The simplest method of pointing and
zooming to a particular object is to place the crosshairs on the object in
question (with a simple mouse click) and then zoom in using the mouse
scroll wheel. The view will automatically centre itself on the object.

Consultation of original measurements and data (6)

The  view  shows  the  objects  from  catalogues  and  tables  in
superimposition - in our example Simbad and Gaia. Each of these objects can be selected with the
mouse, either by clicking on them or by enclosing them in a selection rectangle (click outside any
object - move - release) .

The selected objects appear surrounded by a small green square. The measurements associated with
them appear in the form of a table in the measurements panel. Some values appear underlined in
blue as a "web link".

 
By clicking on one of the links, Aladin will open your browser and display additional information.
The first link is generally used to display the complete original recording, in our example the Gaia
recording from the first source provided by the VizieR catalogue service.

 

Backup (7) 

Aladin offers several backup options in order to keep the current view as an image or a file for
scientific publication, etc. Through the menu " File => Save the current view => PNG " you will
obtain an image file corresponding to the current view easily usable in most office tools.

After this quick introduction to the tool, let's take a closer look at the treatment possibilities offered
by Aladin.
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4 Overview of the data handling options

Aladin supports  the  following  3
main  types  of data  which can be
visualised  in  one  or  several
“views”:  images,  catalogues and
graphical overlays.  A set of tools is
available  in  Aladin   for  each  of
these types of data. 

Aladin “vocabulary” 

➢ An  astronomical  image
represents a field of view in
the sky.  Additional
information about the origin and calibration of the image (position in the sky, pixel size,
projection  type...)  is
usually  provided.  Aladin
supports  two  types  of
astronomical  image:
“regular”  images  (with  a
rectangular  pixel  array),
and  also  HiPS
(Hierarchical  Progressive
Survey) images.      

➢ An astronomical catalog is made of one or several tables whose rows represent information
characterising  one  astronomical  object  or  “source” (typically  including  an  identifier,
position  in  the  sky,
physical  features  etc.).
Aladin  supports  regular
tables in various formats,
but  also tables  generated
dynamically from an HiPS catalog; 

➢ A data collection  is a set of homogeneous data
(images, tables, spectra, etc ), characterised by a
unique name and homogeneously accessed;

➢ A coverage map represents a region covered by a
data  collection  called  MOC  for  Multi-Order
Coverage map . A MOC can not only describe a
spatial coverage, but also a temporal one, or both
simultaneously; 

➢ A graphical overlay represents one or several graphical items (line, circle, polygone...) with
associated positions on the sky;

➢ A  view  is  a projection of a part  of an image,  within which symbols associated to each
catalog source and/or graphical overlays can be plotted;  
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➢ Coordinates in the sky usually represent a pair of  angles (RA – Right Ascension, DEC –
Declination)3.  Aladin  does  not  handle  the  distance  to  the  observer,  but  only  the
representation on the sky.

➢ A date unsurprisingly represents a specific moment in the time scale.

We will briefly describe the various ways one can use Aladin to handle images, catalogs, graphical
overlays and views. 

Image treatment 

Several approaches to handling images are available in Aladin: one
can control the image grey-scale or colour  levels. Images can be
accessed  in preview mode (e.g. jpeg or png) or with their full pixel
values  (FITS).  Different  capabilities  are  available  for  accessing
small or big images, regular images or HiPS. 

The most common image treatment features are: 
➢ Adjusting the pixel dynamics (contrast );
➢ Photometric  measurements  within  polygon  or  circular

areas;
➢ Rotation or other symmetry operations (up / down, right /

left);
➢ Rotation or other symmetry operations (up /  down,  right /

left);
➢ Generation of composite images (creating one color image

from 2 or 3 other color images, mosaics, cubes,...); 
➢ Image resampling as a function of the astrometric solution

of another image; 
➢ Astrometric  calibration  of  an  image  (using  either

parameters or the correspondence with another catalogue or
image);

➢ Pixel  calculations  (sum,  subtraction,  multiplication,
division, convolutions, standardisation);

➢ Extraction of a sub-image from an image;

Operations on catalogues

Aladin  can  handle  two  types  of
catalogues:  Classical  catalogue  tables
where a table can be overlaid on images.
Also,  HiPS  “progressive  catalogues”,
where  the  number  of  sources  shown
depends on the size of the view. Several
operations  are  possible,  according to  the
type of the catalogue:

➢ Handling measurements associated to sources (selection, filtering, sort, pointing,...);
➢ Parametrizing  of  the  graphical  representation  of  the sources  with  respect  to  the

measurements values  (e.g. : drawing of circles whose size is proportional to the magnitudes,
proper motion arrows, errors ellipse);

3 it can also be "Longitude" et "Latitude" in conformity with the chosen spatial reference system.
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➢ Cross-matching between the sources of two catalogues;
➢ Plotting  a  graph-based  representation  of  points  clouds,  given  two  physical  scales  of  a

catalogue;
➢ Calculating new column of measurements; 
➢ Generation of subsets of tables.

 Operations on graphical overlays 

Aladin  handle  several  types  of  graphical  overlay.  Several
operations are possible with respect to the overlay type:

➢ Contour extraction;
➢ Measurements  graphical  tools  (photometry,  angular

distances);
➢ Tagging tools;
➢ Freehand drawings;
➢ Textual annotation;
➢ Image graph-based representations with respect to the

line segment or the third dimension for the cubes.
➢ Superposition of a coordinated grid or constellations;
➢ Image shifts, and rotation. 

Operations on the coverages

Aladin  uses the MOC  (Multi-Order Coverage) to  characterise  sky  coverages.  It  is  a  method to
describe a spatial coverage (i.e. a possibly complex region of the sky), or a temporal coverage (i.e. a
list  of  temporal  periods),  or  both  simultaneously.  This  technique  allows  to  perform  logical
operations (unions, intersections, etc) in an extremely efficient and fast way.
In order to generate a MOC from a data collection, either  the data collection has already been
precalculated and it only needs to be accessed like a data collection derived product, or Aladin can
generate the derived product from the data collection (images, sources, catalogues). 

Operations on views

➢ Superposition of catalogues, graphical overlays, and eventually other images overlays using
the semi transparency functionality;

11



➢ Zooming  and moving;
➢ Multi  view  side  by  side  visualisation  (2,4,9  or 16

simultaneously views);
➢ Views synchronisation  (same scale, same orientation);
➢ Generation of “temporal” view;
➢ Generation  of  “sticker”  view  around  an  object  of

interested;
➢ Full screen visualisation. 

These  different  operations  are  possible  through  an  ordinary
graphical interface. As usual, in order to integrate the various
working habits, several options are available: 

1. the menu bar in the upper side of the main window;;
2. the toolbars (clickable buttons list);
3. contextual menus accessible by right clicking or CTRL

click (Mac);
4. keyboard shortcuts (keys combination).

Note : These operations can also be handled using script commands. See the end of this manual for
more details (see 7.1)

We will next discover, in more detail, different elements corresponding to the graphical interface,
how do they function, etc.
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5 The graphical interface in detail 

Aladin offers a rich and sophisticated graphical interface that allows you to perform most basic
functions in just a few clicks. The main window concentrates all the functions for selecting and
viewing data:

➢ The tree of data collections;
➢ The view(s);
➢ The battery;
➢ The measurements panel.

Several other windows allow various controls, of which the main ones are:
➢ Pixel dynamics control (contrast);
➢ Contour extraction;
➢ The edition of the filters applied to the catalogues;
➢ The calculation of correlations between catalogues;
➢ The calculation and addition of new columns on the catalogues;
➢ Checking the astrometric calibration;
➢ Image resampling control;
➢ Arithmetic operations on images;
➢ The generation of HiPS (progressive readings);
➢ The generation of MOCs (spatial and/or temporal coverages);
➢ Backups;
➢ The management of user preferences (configuration);
➢ The command console for using the scripting mode.

We  are  now  going  to  review  the  different  elements  of  the  interface,  present  their  role,  their
interactions…
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5.1 The main window
Aladin  gathers  in  a  single  window most  of  the  elements  that  are  necessary for  data  selection,
visualisation and exploitation. In the main window, one finds: on the left: the menu side bar, a tree
for data collections ("data discovery tree") and its own filtering system ("Filter"), on the right hand
side: a command panel, a toolbox, a stack with sliders, an information list on top and a multi-usage
panel ("graph") at the bottom, at the center, the main panel displays the views, with a panel for
measures below.

Tip: The relative proportions of the different elements can be modified by locating the mouse at the
interface between the different panels. When the cursor displays a symbol for changing proportions,
click and drag to change the size of the panels. These proportions will be kept from one session to
the next.

Guided Tour

Menu: Help=>Aladin guided tour...
Keyboard shortcut : F1

To help the discovery of the main window, Aladin suggests a "guided tour" that you will find in the
"Help" menu. Once the function is active, use your mouse and move over the different elements of
the main window to see a description of the elements.

5.1.1 Discovery Data Tree
The Discovery  Data  Tree  allows the  discovery,  visualization,  exploration,  sorting,  filtering  and
loading  of  all  available  Aladin  compatible  data  collections.  This  tree  therefore  contains  the
description of several tens of thousands of data collections, coming from different agencies and data
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centers  -among  which  the  CDS  (Centre  de  Données  astronomiques  de  Strasbourg)-  but  also
research projects, and so on. This represents a very large fraction of astronomical data that are
public on the internet.

The structure of the tree is dynamic. It depends on the available
data and of the editorial responsibility of the CDS, especially
for the order of the different divisions. Currently, the first level
of  the  tree  is  divided  in  3  categories:  collections  that  are
selected and sorted by CDS in yellow, and all other collections
in blue. 
The yellow branches of the tree are sorted by CDS along three
criteria: 1- by data type ": "Image", "Catalog", "Cube", 2 – by
highly  used  specific  servers :  "Data  base",  and  3  –  for
outreach :  "Outreach".  Every  collection  at  this  level  usually
appears only once.
The blue branches of the tree also have the same subdivision by
data type, then by the origin of servers. A single data collection
(or a similar one) may appear several times as it may be served
simultaneously by different data centres. It is up to the user to
check and choose the best one for his needs.

Opening  and  closing  branches  is  done  thanks  to  the  small
triangle on the left of each line. This triangle creates an action
at  a  single  depth.  On  the  opposite,  the  icon  located  at  the
bottom of the tree enables the user to open or close the full
depth the selected branch . On the other hand, the order of
appearance of the branches as well as the collections can be
modified by means of the sorting icon located under the tree 
,  either globally or for a particular  branch depending on the
current selection.

Quick access

The main  menu  "File"  has  functionalities  to  open and  directly
access  some specific  branches  of  the  collection  data  tree.  This
menu also hosts ways to filter the data tree.

Filtering the data tree

The easiest way to find a specific collection is to filter the data tree, either by keyword or by more
complex constraints taking into account different
known properties of this collection.

The small form located under the data tree allows you to enable the
filtering functionalities. There are two levels of filtering. The simplest
one is to type a keyword in the "select." field. The tree will then show
only the collections that correspond to this keyword. The number of

15



collections in each branch is labeled on the right of each line and the total  number of selected
collections is displayed on top of the tree. 

For  a  more  advanced  filtering,  one  needs  to  create  a
"dedicated filtering rule" with the icon located at the left

of the form . These rules may be saved and used later
in your future sessions thanks to the menu that unfolds
at the "in" part of the form. How to create filtering rules
is fully described in section 5.4 - Filtering the data tree. 

The "filter" icon at the bottom right is green is a filtering rule is active. Clicking on this
icon deletes this action and restores the original state of the data tree.

Sorting the data tree

A small sorting data tree logo allows to sort the data tree according to  different criteria. It appears
under the data tree, but also in the access  window. Both do almost the same thing, but not quite. 

The one at the bottom is general for the whole data tree, and therefore limited to sortable
global properties. 

On the other hand, the one in the access window applies to the branch concerned, and often
allows more sorting. VizieR branch is a good example because it is possible to sort by popularity as
shown in the example below: 

The Access window 

By selecting a leaf of the tree with your mouse, a specific collection is selected. This is when the
"access window" appears close to the selected collection. In this window, a short description is
given (title,  description, coverage properties, volumes,  …) as well as a set of different ways to
access the data collection and the associated products like a density map, a coverage map (MOC) or
other related collections. 
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Note : Mouse hovering over another entry in the tree will dynamically change the window content
and its position on the screen to stay facing right. If you wish to temporarily suspend this behaviour
in order to be able to preserve the content and manually determine its position, click on the "pin"

icon at the bottom right. .

Shortcut: The most logically used access mode being already pre-checked, it is this one that will be
chosen in case of a direct double-click on the leaf of the tree.

Some access modes require additional information to be able to load the data.  This can be the
designation of the field of view ("by cone"), the selection of a particular region or a specific MOC
("by region or MOC"), the pre-selection of another table ("by Xmatch CDS"), or even the entry of
particular criteria ("by criteria" or "custom").  The input box that appears when the "by cone" check
mark is selected allows you to designate the relevant field of view by indicating the astronomical
object (or the long/lat coordinate), as well as the radius of the interrogation cone. 
By default this box takes the cone covering the current field of view. However, it is possible to
modify  this  default  behaviour,  either  by
entering  the  desired  target  and  radius
directly on the keyboard or by using the
"target" icon  . This will allow you to
specify the query circle directly in the view with the mouse (click/drag) (see 5.2.1). 

Note: Some settings are permanently predefined, but can be temporarily modified for the current

Aladin session via the   icon .

When a multiple designation is entered in the collections tree, either by selecting several leaves
(CTRL and/or SHIFT key enabled) or by selecting one or more branches, the form shows the access
modes  and  collective  derived  products  for  the  designated  collections.  For  example,  it  may  be
possible to request the union or intersection of the spatial coverage of the selected collections.

Locate the collections present in the
field of view

Loading  data  activates  Aladin's  view  and
therefore  automatically  colors  some leaves
and branches of the tree in green or orange.
This color code indicates which collections
in the tree have (green color) or do not have
(orange color) data in the current view field
(spatially and/or temporally). 
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Activating the "view" icon  below the tree temporarily hides collections that do not have data
in the field of view (orange color). Changing the field of view by zooming or moving to another
position will affect the tree after one or two seconds. 

Technical note: This functionality is based on the availability of a description of the coverage of
each collection (a MOC). Unfortunately, this one is not always available. Collections that do not
have them will always appear in white and cannot be filtered. A small alert
symbol will make you aware of it.
 
To overcome this  problem,  Aladin  can  temporarily  generate  missing  MOCs only  on the
current view field using the small "scan" icon below the tree, after selecting the collections
concerned.  This  operation  is  time-consuming  because  it  really  queries  the  servers  of  these
collections. It can therefore only be used on a limited number of collections and in a relatively small
field of view.

5.1.2 The stack
The stack represents all the data loaded in memory that can
be displayed in a view. The stack is structured as a set of
"planes",  named,  and  superimposed  one  on  top  of  the
other. The user observes them from above, in transparency.

Types of planes

Planes can be of different types depending on the nature of
the  data  they  contain.  They  are  identified  by  different
specific logos (see 8.1). Mouse hovering over the logo or
plane name displays information describing the plane in the area above the stack. At the same time,
if  it  is  a  classic  image,  the  corresponding  field  of  view  can  be  temporarily  displayed  in
superposition of the current view.

Pile and the associated view

In the simplest case, the stack contains only one image with a few catalogue planes and/or graphic
overlays centered on the same area of the sky. It is then possible to create a view displaying the
image and overlapping graphic symbols.

To create a view for a plan, there are two methods:
➢ Either by clicking on the check mark to the left of the plan logo ;
➢ Or by "clicking/sliding/dropping" the plan logo from the stack to the view.

To activate another plane in the same view, click on its logo .The proportion of grey in the
logo indicates the level of semi-transparency. When the logo is completely greyed out, the plane is
fully activated. 

Tip: It is possible to create a view based only on a plane - catalog, without a background image. To
do this, you must use the "click/drag/drop" view creation method described above.

Another image plane of the same field can be inserted in the stack in order to compare these two
images, either by semi transparency (see corresponding section), or alternatively by clicking on the
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check mark of one image then the other, or by creating a composite plane (false colors or blinking
planes).

     

It is also possible to simultaneously load image planes and/or catalogues in the stack that do not
represent the same position in the sky. The visualization of the two sky zones can be done either
alternately by activating one or the other of the respective image planes, or simultaneously by using
several views displayed side by side (see 5.1.3).

Hierarchical structure

In order to facilitate the organization of the stack, it may be desirable to group certain plans into a
folder or even a sub-folder.  The creation of a folder is done either by the
main "Edit" menu, or by using the contextual menu of the stack (right
click or CTRL click).

Contextual menu

The stack has a contextual menu accessible by using the right button
(resp.  Apple+click  for  Mac).   This  menu  contains  all  the  functions
specific to the manipulation of planes, for example their deletion, or the
display of their properties. 

Selection

Selecting a plane from the stack is done by clicking on its name - not on
its  logo  (plane  activation).  The  selected  plane  appears  with  a  blue
background.  It  is  possible  to  select  several  planes  simultaneously  by
holding down the Ctrl key, or Shift key if it is a group of consecutive
planes. Some items of the main menu, or the contextual menu, as well as
the toolbar icons will be enabled or disabled depending on the nature of
the selected plan(s). For example, if it is an image plane, the "contour"
button will be activated.

Properties

Icon: prop.  
Menu : Edit > Properties
Shortkey : Ctrl + Enter
Script : set…, status …
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The  display  of  the  "properties"  of  a  plane  is  done
either by the "prop." button, by the main menu "Edit
=> Properties" or by the contextual menu of the stack
(right click or CTRL click).  The window that  opens
shows both the generic properties: name of the plane,
origin of the data... but also the properties specific to
the nature of the plane. This window also allows you
to modify  some of  these  properties.  For  example,  it
will be possible to change the graphic symbol used to
draw the sources of a catalog or to adjust the rotation
angle of an instrumental field of view. The properties
window also allows you to view or even copy the Web
address used by Aladin to obtain the data.

Transparency control

Some  planes  can  be  displayed  in  semi-transparency
over the background image. It can be a catalogue plane
or one that contains an instrumental field ("FoV") or
an "image" plane above another image. Whenever possible,  the logo of the plan in question is
provided with a small stick. This can be dragged to the right to increase the opacity level of the
plane, or to the left to decrease it.

 
Tip: In order to have a larger slider, the transparency level can also be controlled either by the
"opac." slider. "located under the stack, or directly in the properties window.

  

Various tips and tricks

➢ At the bottom right of the view, an icon symbolizes the observer's eye . This element
can be  clicked  to  hide  all  the  graphical  plans  with  a  single  click  and  display  only  the
background image. A second click on the eye will restore the previous configuration.

➢ To help  you  locate  the  data,  double-clicking  on  the  plane's  logo  will  briefly  flash  the
associated data during a few seconds.  
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➢ A catalogue plane at the top of the stack will by default be systematically projected on all
images of the same field located below it. In the case of the multiview (see next section) it
may be interesting to restrict the
projection of a catalogue plan to
a  particular  image.  To do this,
simply place the catalogue and
the image concerned in the same
"folder".  Then  via  the
"properties" associated with the
"folder",  select  "scope:  local":
the  folder  then  appears  as  a
closed  envelope  and  the
catalogues  found  there  are  no
longer plotted on the other images.

 

5.1.3 Control sliders
Below  the  pile  there  is  a  set  of  rulers.  They  allow
various controls:

➢ J2000 : Adjustment of the time of the view. If
the sources of the selected plane have their own
proper motions, the objects will be displayed at
the specified year. By default,  the year of the
current image if it is known, is taken, otherwise the year 2000. Clicking on the title of the
slider resets it to its original value;

➢ Size: modifies the factor to be applied to the size of the graphic overlays of the selected
planes;

➢ Dens.: Modification of the density. In the case of a HiPS catalog plane, the action of this
slider will temporarily change the HiPS order4 selected for the field of the view, and thus,
modify the density of the sources that appear in the view. In the case of a coverage plane, the
change in density changes the maximum order of the MOC used to view this coverage. 

➢ Cube : Choice of the current image of a cube. In the case of a selection of a cube plane, or
HiPS cube, the action of this ruler allows to adjust the "slice" of the cube to be displayed in
the view;

➢ Opac. : Changing the opacity. When a plane is displayed in overlay of another plane, this
slider affects the transparency level of the foreground. This function is also possible via the
small slider directly under the logo of each shot in the stack;

➢ Zoom : Changing the zoom factor of the view. 

Technical note: some of these sliders may not be present in your interface. You may then add them
using your user preferences (see 5.21).

4 In this context, the order of a HiPS or MOC represents the level of resolution used for the display (see 6.2). This is the
surface of the HEALPix diamond associated with this order.
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5.1.4 The view
The view panel (or views) is the main element of the
Aladin interface. The view displays a representation
of the activated data in the stack. In general, it is an
image on which symbols representing the sources of
the  catalogues  are  superimposed.  Information
elements  located  at  the  edge  provide  additional
information: a title (label), a reticle, a scale, the size
of the field on the sky and its orientation.

Location of objects in the view

To plot astronomical objects  at  their  exact  position,
Aladin uses the astrometric solution associated with the image, for example a centered tangential
projection. In general, images, especially those encoded in FITS format, or progressive surveys
(HiPS) are provided with an astrometric solution. If this is not the case - for example for a JPEG
image - it  is possible to calculate your own astrometric solution (menu:  Image => Astrometric
calibration - see  5.14). It may happen that objects do not overlap exactly with the image either
because their positions are not precise or because the astrometric solution is uncertain.

Activating planes

Icon :  
Script : show … , hide …

The planes that appear in the view are the ones that have been activated in the stack by clicking on
the corresponding icon.  Once activated, a double-click on this logo will briefly flash the data to
make it easier to locate. It is possible to adjust the transparency level, or even temporarily hide one
or the other of the planes, or even the background image (see 5.1.2).

Switching to the next image

Menu : View => Next image
Shortkey: Tab

When the stack contains several images, it is possible to quickly switch from one image to
another by simply activating the corresponding image plane. Automatically, all graphical
planes (catalogues and drawings) that can be superimposed on the image will be activated.
Using the "View => Next image" menu or the "TAB" button performs the same operation.
This feature is particularly useful  when the view is viewed in full  screen or in a single
window (see below).

Semi-transparent image

Icon :  
Script :set … opacity=[0..100]

It is also possible to display a semi-transparent image over another image. This is especially useful
when the image to be displayed in transparency is smaller than the background image. To activate
the semi-transparency of an image, it is necessary to use the small slider that appears under the logo
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of  the  projected  image plane.  When  the  slider  is  fully  pulled  to  the  right,  the  top  image  will
completely hide the corresponding portion of the bottom image.

It may be useful to switch the image planes in the stack to change the images in the foreground and
background.

Reticle

Menu : Overlay => Simple/Large reticle…
Script : coordinates or object name

The reticle are used to identify a particular position in the view. In general, this is the last position
clicked. The reticle can be drawn either as a small magenta cross or as two straight lines crossing
each other transversely. It is also possible not to display
it  (Overlay  menu => Reticle).  The  coordinates  of  the
reticle  are  displayed  in  the  "Command"  field  of  the
"Command Banner". Conversely, entering a position, or
even an object name, in this field causes the reticle to
move to the corresponding position.

Tip:  It  is  not  necessary  to  click  in  the  field,  you can
directly  enter  your  target  on  the  keyboard  even  if  the
cursor is in the main view. 

The 5 actions in the view

The actions performed by the mouse in the view are:
➢ Select: selection of graphic overlays, including catalogue sources;
➢ pan : shifting the field of view;
➢ Zoom : enlargement / reduction of the field of view;
➢ Rotation :change of view orientation;
➢ Time-based filtering: time display restriction.

     

The first 2 modes are exclusive, and by default, the "Select" mode is activated. Before performing a
mouse action, take a look at the toolbar to make sure you are in the desired mode.

Tip: When there is no object to select, the Pan mode will replace the default Select mode. 

Objects selection:

Button: select  
Mouse : click  or click/drag

When Aladin displays graphical objects (astronomical catalogue sources or graphical overlays), it is
possible to select some of these objects when the "Select" mode is activated. If this is not the case,
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click on the "select" button at  the top of the button bar.  The selection of an object is done by
clicking on it or by creating a selection rectangle encompassing the object or objects concerned
(click outside any object, then drag and drop). The selected objects are surrounded by a small green
square. For astronomical sources, the associated measurements appear in the measurement panel
below the view (see 5.1.8).

The selected objects  - when it  is graphical overlays and not catalog sources - can generally be
moved. To do this, it is necessary to click/drag one of the small green control squares that were
displayed during the selection. In addition, in the case of instrumental fields of view (see  5.2.3 -
FoV), the corners will allow rotation.

Pan mode

Button: Pan   
Menu : Edit => Pan mode
Shortkey: Alt+Z
Mouse: click/drag middle button

It is possible to drag the image by using the "Pan" button and then click and drag the image in the
desired direction. 

Tip:  Using  the  middle  mouse  button  allows  you  to  directly  perform a  "Drag  & Drop"  while
remaining in "Select" mode.

Zoom

Slider: zoom  
Menu : Edit => Zoom…
Shortkey: F2, F3 -  F4 (pointed zoom)
Mouse: wheel
Script : zoom …

Aladin allows you to quickly zoom in on any portion of the image. 

The zoom factor can be changed in different ways :
➢ By manipulating the mouse wheel with the pointer in the view;
➢ By using the slider below the stack;
➢ By using the main menu "Edit => Zoom";
➢ By using the "pointed zoom" menu and then clicking in the view (hold down the Shift key to

"zoom out"). To quickly return to the default mode ("select"), move the mouse pointer out of
the view panel.

If the image has an astrometric calibration, an increase in the zoom will center the image on the
current position of the reticle (unless the view has been "locked" - see below). It is therefore very
easy to zoom in on a particular object by moving the crosshairs over the object (single click) and
then using the mouse wheel.
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Contextual Zoom & pan 

Zooming  and  paning  operations  can  also  be  performed  with  the  mouse  and  wheel  using  the
contextual "zoom graph" that appears at the bottom right. In the case of a visualization of a classic
image, it presents the entire image in the form of a thumbnail, and in superposition a blue frame
represents the region currently visible in the view. For
progressive surveys (HiPS), the thumbnail is replaced
by a  global  representation  of  the  celestial  sphere  in
AITOFF projection on which is located the currently
visible field of view.

Location history

The history of the different targets is stored and accessible through the drop-
down menu displayed in the contextual "zoom graph" described in the previous

paragraph. These positions are stored from one session to the next. By default, these are all targets
that have been queried on a server. It is also possible to manually add the current position of the
reticle by clicking on the symbol to the left of this drop-down menu.

Rotation

View :
Mouse : Ctrl + drag/drop
Image type : HiPS only
Script : northup …, unnorthup …

The rotation operation allows the image to rotate in the view. The easiest method is to use the
mouse as if you were moving the view, while holding down the Ctrl key. It is also possible to rotate
the North-East direction indicator directly, without having to hold down the Ctrl key.

To cancel the rotation and redirect the north of the image to the north, click on the "North"
icon located below the view.

Restriction of use:  Rotation is only possible on progressive surveys (HiPS). The classical
images can only be temporarily reoriented to the North at the top via the "North" icon, but
without the possibility of choosing another rotation angle.

Time filtering

Menu : View => Time range filter
Script: ISODATE1 ISODATE2

Any view can have a time window associated with it in the form of a start date and an end date5.
Therefore, only data falling within the time window will be plotted (catalogue sources, portion of
space-time coverage (STMOC). Data without time stamps will also be displayed.

5 The time reference is TCB or Barycentric Coordinate Time
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If time filtering is applied, the relevant date range is displayed beside the field size of the view
(bottom middle of the view).

With the mouse, it is possible to dynamically adjust the time window
associated to the view by using the controls of the time slider (opening
and closing bracket) which appears in the Aladin tracking panel. The
deletion of the time window, and therefore of the associated filtering,
is  done by clicking on the small  cross appearing to  the left  of the
upper time boundary, or more simply, by double-clicking in the time
interval delimited by the 2 brackets.

Coordinate grid

Icon : grid    
Menu : Overlay => Coordinate grid

 Overaly => HEALPix grid
Shortkey: Alt+G
Script :grid …

The activation of a grid is done either by the "grid" icon located under the view, or by the "Graph
=> Coordinate grid" menu for a grid in longitude / latitude or "HEALPix grid" for a HEALPix grid
(see 6.2). The grid spacing depends on the current zoom factor to display only a reasonable number
of segments. The grid frame is the same as the
one used to display the current position under
the mouse. It is not possible to display several
grids  simultaneously  in  different  frames  of
reference.

In the case of a  grid in  longitude /  latitude,
when  the  view  is  very  wide,  the  grid  may
appear  partially  truncated  if  the  astrometric
solution of the current image cannot be used
to calculate a position very far from the image
(e. g. digitalized Schmidt plate).

Multiple views or "multiview"

In order to easily compare multiple images, it
is  convenient  to  create  multiple  views
simultaneously.  The  main  panel  can  be
subdivided into 2, 4, 9 or 16 subpanels. Each
of these panels can display a different image and superimposed graphic objects. These images may
be of different regions of the sky and/or the same region of the sky. It is also possible to use several
panels for the same image, for example to view several details of the image.

Restriction: Note that in the case of HiPS, this last function is only possible after duplicating the
HiPS plane as many times as there is a view.
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Number of views

Icon : multiview    
Menu : View => Panels => 1 panel, 2 panels …
Shortkey: Maj-F1, Maj+F2, Maj+F3, Maj+F4
Script : mview …, cview …

The number of "visible" views can be changed either by using the "multiview" switch located at the
bottom left under the view panel, or by using the "View => 1, 2, 4, 9, or 16 panels" menu.  In case
there  are  more  views used  than panels  available,  a  scroll  bar  appears  to  the right  of  the main
window to  access  the  other  views.  It  is  possible  to  manage several  thousand views  (see  6.7 -
creating thumbnail views). Only visible views actually use RAM.

Assigning views

Assigning an image to a view is done by dragging and dropping the logo of the corresponding plane
of the stack into the selected panel.
It is also possible to create as many views as there are images in the stack in a single operation
using the "View => Create one view per image" menu.

Tip:  It  is  possible  to  drag  and  drop  a  JPEG,  PNG,  FITS image  from your  work  environment
(Windows desktop, Desktop Linux...) and/or from your web browser to a particular view.

Current View

The current view is surrounded by a blue border, i.e. the one on which the zoom functions will be
operated, for example. Simply click on a view to make it the current view. By holding down the
Shift  key,  you can  select  multiple  frames  simultaneously,  for  example,  to  indicate  which  ones
should be deleted.

It is possible to view the current view (blue border) in "monoview" by returning to a single panel.
The other views are not deleted and are always accessible via the vertical scroll bar that appears to
the right of the window or when returning to multiview mode.  The current view can also be viewed
in full screen ("View => Full screen" menu) or in single window mode ("View => Single window"
menu) - see below.

Matching views

Icon : match   
Menu : View => Match…
Shortkey : Alt+S, Alt+Q
Script : match …

In multiview, it is possible to match the scale, even the orientation of different images but for the
same region of the sky. This operation is  accessible  either  through the menu "View => Match
scales" or "View => Match scales and orientations". Or, in the latter case, by the "match". The
match between scales applies only to standard images. It does not change the pixels, but simply
automatically selects the nearest center and zoom factor to view the same area of the sky. On the
other hand, the match of scale and orientation reprojects the images either based on the position of
the 4 corners of each classic image, or by using the same HiPS projection for progressive readings.
Thus  the  fields  of  view  are  identical  but  the  pixels  are  distorted.  The  "matched"  views  are
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automatically selected, identifiable by their blue edges. If their orientation has also been aligned, the
edge of the concerned views appears in red.

Locked view

Menu : View => Locked view
Script : lock …, unlock …

When double-clicking in a view, all other views for the same region of the sky will automatically
center on the clicked position. The same applies if you click in the measurements (see 5.1.8).  To
inhibit  this  zoom change, it  is  possible to lock a view so that it  always keeps the same center
( "View => Locked View" menu). A locked view shows a small lock in its lower left corner.

Move and copy

It is easy to move a view from one panel to another by simply clicking, dragging and dropping it
with the mouse and having previously positioned the mouse pointer on the edge of the view to be
moved. The cursor changes shape to indicate that copying/moving is possible. Holding the Ctrl key
simultaneously with this operation will duplicate the view.

Deletion

Deleting a view does not mean deleting the image and/or catalogues used for that view; the data
remains accessible in the stack. On the other hand, deleting an image in the stack will delete all the
views that use it. The "View => Delete other views" menu allows you to quickly delete all views
except the current view.

Full screen and simple window modes

Icons:  
Menu : View=>Full screen, Simple window
Shortkey : F11, F12

A view can be displayed using the entire screen. It can also use a single window. In both cases the
adjacent panels (stack, measurements, trees, ...) will no longer be displayed directly, but can still be
accessed using control buttons on top of the view. A click on one of these buttons turns it into a
control  panel  displayed  in  semi-
transparency above the view. These control
panels can be moved and modified in size
and  transparency  by  clicking  on  them  in
order to make the control handles necessary
for these actions appear. The mouse wheel
in  the  top  margin  allows  the  transparency
factor to be changed. 

Moving  the  mouse  over  the  top  of  the
window temporarily brings up the menu bar.
Typing  on  the  keyboard  will  open  a  text
field to submit an object, position or script
command.

By using the "F11" or "F12" key, you can switch to these viewing modes. The "  Esc " key  will
return to normal display mode.
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5.1.5 The main toolbar 
Located between the stack and the view, vertically, the "toolbar" provides quick access to the most
commonly used tools:

➢ select Mode : selection of objects in the view
➢ pan Mode. : moving the view

➢ dist Graphic overload of distance measurements
➢ phot Graphic overlay of photometric measurements
➢ draw Graphic overlay of freehand drawing
➢ tag Graphic overlay for brand positioning
➢ spect Supercharge graphic extraction of a spectrum from a cube

➢ moc MOC handling tool (blankets)
➢ filter Catalogue filter generation
➢ cross  Catalogs correlation cross tool
➢ x-y Generation of a scatterplot graphic
➢ rgb Colour image generator
➢ assoc Generator of image associations (mosaics/animated seq.)
➢ crop Extraction of a sub-image or sub-MOC
➢ cont Generator of contours
➢ pixel Opens the Pixel Dynamics Control window.
➢ prop Opening the properties window
➢ del Deleting the current item

Activation

The buttons are activated according to the shots selected in the stack. Some buttons remain grayed
out if they are not affected by the shot type or if the number of selected shots does not correspond to
the action to be taken.

Help

Holding the mouse on one of the buttons will display a small window with a brief explanation of the
action of the button ("tooltip"). The extended waiting time will be completed by a more detailed
explanation in the free area above the stack.

Modes and tools

The first 2 buttons concern the modes of action of the mouse in the view to select objects, move the
view field (see above, the view modes). These are exclusive buttons. All the other buttons concern
tools.  In this  section we will  only detail  those tools that  have not  been described in  the other
sections of this document.

Graphic tools: dist., phot. draw, tag and spect. 

Buttons:      
Menu: Overlay=> dist, photo, draw, tag, spect
Shortcut: Alt+D (distance)
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Script: draw ...

The 5 buttons give access to the graphic overlay tools for distance measurements,  photometric
measurements,  freehand  plotting,  marker/text  placement.  Activating  one  of  them automatically
creates a "graphic overload" plan on the top of the stack. The graphic elements that will be placed
with the mouse in the view will be stored in this plane, with celestial coordinates, and can therefore
be viewed on other images. 

Selecting and moving

Graphic overloads created by one of these 5 tools can be selected (Select tool) or even moved by
means of a mouse click/move. When they are selected, small green handles appear on their edges or
ends. 

Technical detail: When several
elements  are  moved
simultaneously,  the  movement
is  calculated  on  the  celestial
vault  (in  RA,  DEC)  only  for
the object under the mouse and
then  transferred  to  the  other
objects  concerned.  Holding
down  the  Shift  key  changes
this behaviour to consider only
a movement in XY coordinates
for  all  objects.  These  two
techniques  do  not  give  the
same result, especially when the objects to be moved are several degrees apart or close to the poles.

Viewing and modifying properties   

After  selecting  a  single  graphic  overlay,  it  is  possible  to  display  or  even  modify  the  specific
properties  of  this  graphic  element  by  clicking  on  the  "Properties"  button  or  via  the  "Edit  ->
Properties" menu. This can be its position, size, colour, title, etc...

A few tips

➢ It is possible to display the position of a mark next to it.  To do this, select the mark in
question and use the context menu (right click or CTRL click) and select  "display object
identifier".

➢ When drawing freehand ("drawing"  tool) you can either hold down the mouse button to
draw a "continuous" drawing or click several times to draw successive straight lines. In the
latter case, it is necessary to take the pointer out of view to stop the drawing process or
double-click for the last vertex.

➢ To create a polygon using the drawing tool, the last control point must coincide with the first
point. To help you, the cursor changes shape when you fly over the first vertex again.

➢ In order to create a new  drawing  so that the new graphic overloads are not in the same
graphic plane, it is necessary to first create a graphic plane level via the menu "Graphic >
create new drawing plane" (Alt+N).
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Cutting graph associated with the distance tool   

When the double arrow used to measure a distance has been selected in the view, the multifunction
panel  -  at  the  bottom  right  of  the  main  window  -  displays  a  "slice  graph"  representing  the
distribution of pixel values along the segment measuring the distance. If this segment is moved in
the view with the mouse, the slice graph changes according to the position in the image. On the
other  hand,  if  you hover  over  the  slice  graph with the  mouse,  a  horizontal  bar  allows  you to
calculate the distance, angular and in
pixels,  of  a  particular  peak.  For
example, this method can be used to
quickly  approximate  the  width  at
mid-height of a star.

On the  other  hand,  in  the case of  a
true colour image (see 8.1 - supported
data  types),  the  levels  of  the  3
components  Red/Green/Blue  will  be
plotted simultaneously.

Photometric measurements associated with the "phot"   and “draw”   tools   

The photometric measurement tool can be used in two ways: either automatically by extracting a
star from the image in the view by a simple click on it, or manually by a click/extend to draw a
circle of a specific radius. In the first case, Aladin will use a barycentric measurement algorithm to
determine  the  central  position  of  the  astronomical  object  as  well  as  the  parameters  of  an

encompassing ellipse.  In the second
case, there will be a simple statistical
calculation of the pixels inscribed in
the  circle  or  the  polygon:  count,
mean, standard deviation, minimum,
maximum, sum... 
These measurements are displayed in
the multi-purpose panel on top of the
pixel value distribution histogram.
It  is  possible  to  save  the  statistical
measurements by pressing the "save"
button  on  this  histogram. The
calculated  measurements  are
associated to the photometric object
and  can  be  consulted  and
manipulated  (sorting,  selection,
saving,  ...)  in  the  measurement
window  under  the  main  view  (just
like a classic catalogue). 

Application restrictions:  The original pixels of the astronomical image to which the photometric
tool is applied must necessarily be available (not possible for a JPEG or PNG image), whether for a
conventional image, or for a progressive HiPS reading. And in the latter case, only the manual circle
mode is available.  Please note that only pixels whose centre is within the circle are taken into
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account in the calculation of the statistics. A sufficient zoom will show a point at the centre of each
pixel concerned by the statistical measurement.

Note: When the automatic extraction algorithm fails to determine the centre of the object under the
mouse, no mark is inserted.

Note: In the  case of HiPS progressive scan measurement,
pixel extraction is performed at the current view resolution.
The order of this resolution is indicated as a prefix to the
name of the image on which the measurement is taken. This
means that for low zoom factors, statistical calculations will
be  performed  on  pixels  that  are  already  the  result  of
averaging pixels of higher resolutions.

Depth cutting associated with the "Spect" tool     

The positioning and selection of a mark by the "Spectrum" tool in an image cube also generates a
cutting graph just like the "dist" tool, but this time in the direction of the depth of the cube. On the

graph thus obtained in the multi-purpose panel,
the vertical red line corresponds to the position
of the current image of the cube (a cube under
Aladin is displayed as a sequence of images).
The value at the foot of this mark indicates the
physical quantity corresponding to the current
image of the cube (e.g. a speed). As with the
distance  tool,  moving  the  marker  with  the
mouse automatically adjusts the graph. On the
other  hand,  hovering over  the graph with  the

mouse displays the value of the corresponding pixel (ordinate of the graph). A horizontal click/drag
will move the red line of the current image and thus move the current image in the view.

Note: The use of the "Spect", "Phot" or "Draw" (polygon) tools on a cube are capable of generating
a spectrum respectively pointed or averaged over the area which will be viewable and manipulable
using the CASSIS plugin developed by IRAP/Toulouse. Please refer to section 6.5 for details.

Special features of the tool “  Tag   .”  

The "tag" tool can be used either with a simple
click or by clicking/dragging.

A single  click  inserts  a  cross  identified  by  a
serial number at the exact location of the mouse,
to  which  are  associated  positioning
measurements in X, Y (origin at  the FITS, i.e.  (0.0) in the middle of the lower left  pixel)  and
longitude, latitude presented in the measurement window. These measurements can be manipulated
like a classic catalogue (sorting, selection, saving...).
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Click and drag insertion allows the creation of a more complex
"tag", accompanied by the entry of a text associated with the
tag. It offers a more sophisticated visualization (positionable
text  stem,  selectable  end  of  the  stem,  size,  border  and
background of the text that can be modified, ...). However, no
positioning measurements are stored. 

It is often more convenient to modify a posteriori the specific
parameters of such a tag by displaying its properties ("Prop."
button after selecting the tag).

The "magnifying glass" or "pixel table" tool  

Menu: Image => Magnifier glass, Pixel table
Shortcut: Ctrl+G

When the magnifying glass is activated, the multi-purpose panel - at the bottom right of the main
window - will be temporarily used to display an enlargement of the pixels around the mouse pointer
as it hovers over the view.
Using the arrow keys (up, down, right, left
arrows)  makes  it  possible  to  move  the
mouse pointer pixel by pixel.

It is also possible to select the display of the
pixel value table under the mouse. This is a
display similar to the magnifying glass, but
with  a  higher  magnification  so  that  the
values can be displayed in superimposition.

The cutting tool 

Button: cut  
Menu: Image => Crop image area 
Type of images: HiPS or classic images
Script: crop ...

The cutting tool allows you to extract a sub-image from a previously loaded image. This can be of
any type, classic image, in colour, in real pixel values, or even from a progressive HiPS reading. By
activating this tool, you can delimit the rectangular extraction area with the mouse. Once the area
has been delimited, it is possible to manually adjust the positioning values a posteriori by clicking
directly in the cartridges and then editing the appropriate values.
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The extracted image is automatically inserted
into  the  stack.  In  the  case  of  a  greyscale
image, its colour table will be inverted so that
it can be easily located by superimposing it
on the original image.

Technical  note:  In  the  case  of  an  image
extracted  from  a  progressive  scan,  if  the
progressive  scan  is  displayed  in  preview
mode,  the  extraction  process  is  a  simple
visual capture of the sub-image, fast but not
free of distortion.  On the other  hand,  when
the progressive survey provides access to the
true pixel  values,  the extraction will  be the
result  of  a  pixel-by-pixel  bilinear  sampling
process to ensure that the original astrometry and photometry is optimally preserved. The choice of
the final  resolution of such an extracted image can be adjusted either  by modifying the factor
indicated  at  the  bottom left  of  the  extraction  rectangle,  or  by  ticking  the  "original  resolution"
selector at the top left. It is recommended to check the corresponding size in pixels at the selected
resolution before starting the extraction operation.

Tip: The same cutting tool can be used on a MOC in order to extract a rectangular under MOC.

The deletion tool

Button:   
Menu: Edit => Delete

Edit => Delete All
Shortcut: Del or Shift+Del
Script: rm and reset

The delete  tool  is  context  dependent.  Depending on the element(s)  selected with the mouse,  it
deletes either:

➢ The graphic overloads;
➢ The views;
➢ The plans.

On the other hand, pressing the "Shift" key at the same time will delete all the data loaded into
Aladin. Notice that Aladin does not have an "undo" function.

5.1.6 The secondary toolbar 

Located under the data collection tree and under the view, the sub toolbar allows the actions de-
scribed below.

Collection tree (see   5.1.1  )  :  
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➢ coll.: Development/reduction of the selected branch;
➢ sort: Sort the collection tree according to various criteria;
➢ view: Filtering of collections that do not have a result in the current view;
➢ scan: Dynamic creation of a cover for collections that do not have one;
➢ filter: Activation of filtering.

View:
➢ grid: Activating the coordinate grid;
➢ study : Examination of the astronomical object under the mouse (see 5.9);
➢ wink: Temporarily suspends the display of graphic overloads in the view;
➢ redo: Update of stack plans produced by a cone query;
➢ north: Forced rotation North at the top, East on the left;
➢ hdr: Switches from preview viewing mode to real dynamic mode (HDR for "High Dynamic

Resolution");
➢ multiview: Control of the number of views visible simultaneously;
➢ match : Temporary use of a single projection for all selected views.

5.1.7 The command banner 
In the upper part of the main window, below the menu, a control bar groups four control elements:

➢ The command field;
➢ The spatial referential selector;
➢ The current projection selector;
➢ The list of bookmarks.

The command field

The command field is used for a variety of purposes: viewing coordinates under the mouse as it
hovers over the view, entering a position, coordinates, or a script command.

Entering a position

The main function of the command field is to enter an astronomical position. The coordinates of the
target must be entered as a longitude and latitude pair. The reference frame used must correspond to
the one specified (ICRS, J2000, B1950d, XY image,...) in the selector on the right of the input field.
The validation of the position entered by the Enter key causes the crosshair (magenta cross) to be
moved to the corresponding position in the view and the view to be centred on this position. 

It is also possible to enter an astronomical object identifier. In this case the validation (Enter key)
will first automatically query the "CDS Sesame" service, which will return the best known position
of the object by consulting the Simbad and NED databases andcertain large VizieR astronomical
catalogues. Then, based on the recovered coordinates, Aladin will move the reticle and centre the
view on this position. This function is also accessible via the menu  " Tool => Resolution of an
object name ".

Tip: If  the view is still  empty, entering an astronomical position or object identifier will load a
default astronomical survey - usually the colour DSS (which can be changed by user preferences –
see 5.21).
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Script command   

The position field can also be used to enter any script command supported by Aladin, not just a
position (see 7.1 - Aladin by script). On the left side of the input field, a small triangle opens a drop-
down menu of the history of commands executed by Aladin. This list contains not only the previous
script commands executed, but also commands equivalent to a previous action performed using the
graphical user interface and the mouse. You can then re-execute the same action, or even edit and
modify it before re-executing it.

The reference frame and projection selectors 

The two selectors  to  the right  of  the control  field are
used to  indicate  on the one hand the spatial  reference
frame  used  by  default,  and  on  the  other  hand  the
projection used for display in the view. 

Note:  the suffix "d" in  some of the proposed reference
systems means "degrees"  and indicates that the display
and  entry  of  coordinates  will  be  done  in  decimal
numbers  (e.g.  256.67555  -47.17031)  and  not  in
sexagesimal notation (e.g. 17 06 42.1320 -47 10 13.116)
(see glossary).

The modification of its selectors will be reflected in the view, either by a simple
adjustment of the coordinate grid in the case of classic images (only the reference

frame will be modifiable in this case), or by the transformation of the image itself in the case of a
progressive HiPS survey in order to plot it in the reference frame and the chosen projection. For
example, it is possible to visualise the complete vault of the sky in galactic referential / AITOFF
projection or in equatorial ICRS / spherical projection, etc.

  

Tip:  in  multi-view  mode,  it  may  be  desirable  not  to  display  all  views  in  the  same  frame  of
reference / projection. To do this, it is necessary to choose a specific reference and projection via the
properties of the planes associated with each view.
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Bookmarks 

Below the command field, a list of bookmarks provides quick access to predefined actions. This is
usually the loading of a specific collection for the current position, but it can be any type of action.
The  bookmarks  marked  with  a  green  "bookmark"
have been predefined by the CDS, the blue-grey ones
are defined by you.

Hovering  over  a  bookmark  displays  after  a  few
seconds the script command(s) that will be executed if the bookmark is executed by clicking on it.
You can update the list of bookmarks visible in this bar, as well as create or modify bookmarks by
clicking on the "+" icon on the far right of the bookmarks bar, or via the "Tools -> Bookmarks..."
menu.

Tip: The bookmark symbol  displayed in various places in the Aladin interface, particularly in the
"access window" of each collection, allows you to immediately create the corresponding bookmark.

Now let's take a look at the bottom of the main window: the "measures panel".

5.1.8 The measures 
The "measurement panel" is located at the bottom of Aladin's main window. It is used to view the
measurements associated with the sources. It is a very powerful tool that allows you to select, sort
and filter tables.

Note:  This panel is retractable and may not be visible. If this is the case, click on the small tab
symbolised under the view.

Only sources that have been selected, individually or collectively,  thanks to the mouse view (see
5.1.4) appear in the Measurements panel. These measurements are presented in the form of a table
where each line shows the values associated to a source.

Selected sources appear surrounded by a green square in the view. Hovering with the mouse over a
selected  source  causes  this  source  to  blink  and  simultaneously  makes  the  corresponding
measurements visible by highlighting the line in blue. Symmetrically, hovering over a line in the
measurements table causes the corresponding source to flash in the view if it is visible. On the other
hand, selecting a line in the table (by double-clicking on it) will move the view to centre it on the
corresponding source. 

The  first  line  of  the  table  displays  the  header  that  describes  the
contents of each column. Clicking on a header box sorts the rows in
ascending  and  descending  order  according  to  the  values  in  the
column. A small triangle appears to the right of the label to indicate the sort column. The sorting
will be alphabetical or numerical depending on the contents of the column. The width of a column
can be enlarged or reduced by clicking and dragging the right edge of a box in the header. When a
cell  is  still  too narrow to  display the  full  value,  hovering  the mouse  over  the cell  temporarily
enlarges it to reveal the rest of the value. 
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Measurements from different catalogues

If the selected sources come from different catalogues, several tables which do not necessarily have
the same columns will follow one another. The colour of the square at the beginning of the line
allows you to quickly identify the origin of the data (same colour as the plan in the stack).

The  header  line  always
corresponds to the table of the
last selected line (clicked with
the  mouse),  or  to  the  one
pointed under the mouse. The
colour  of  the  line  under  the
header  follows  the  colour  of
the corresponding catalogue.

Cell information 

If you hover over a measurement cell, additional information associated with that cell is displayed
in the free area above the stack. This will include the table title, the field name, its value, its unit,
the UCD (Unified Column Descriptor) associated with this column and its description.

Histogram of column values 

By hovering over a column in the measurement table, the histogram of
the distribution of the values in this column appears in the multi-pur-
pose panel on the right. Moving the mouse over one of the bars of this
histogram restricts the display in the view to these sources only. In the
case of a numerical series, the width of the bars can be modified by us-
ing the mouse wheel.

Links and buttons 

As in a web browser, the values marked in blue are "links" to additional information available on
the net. The web address that will be called up is displayed at the bottom of Aladin's window when
the mouse pointer hovers over the link. A mouse click on a link opens your web browser, which will
load the corresponding web page.
Usually the first link of a measurement line will load the original registration page of the website
that provided the data (Simbad, NED, VizieR...).

Some values can also be displayed as a button. Just like a web link, the activation of such a button
causes additional data to be loaded via the net. However, instead of opening your browser, the data
will be inserted into the stack so that it can be viewed immediately in Aladin. Most often these are
archive images associated with a list of observations.
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Datalink

It can happen that several links are associated to the same button. These links appear in the form of
a  small  drop-down  menu.  This  multiple  choice  system  called  "DataLink"  may  require  an
intermediate form to be filled out in order to
load the data designated by the selected link.
This  may  be,  for  example,  to  specify  the
portion of the original image to be loaded.

Context menu 

The measurement window has a number of
functions  that  can  be  accessed  via  a  right-
clickable context menu.

In  particular,  this  menu  gives  access  to
various functions for using the clipboard to
make  a  copy/paste.  It  also  offers  the
possibility to create a new catalogue plan containing a copy of the sources/measurements present in
the measurements window. This duplication can be done identically ("in multi-tables if necessary")
or in a regenerated table in order to merge tables that may not have the same column structures and
names. 

Tip: In  order to easily compare two possibly
non-consecutive  lines,  the  "View  Record"
menu allows you to view the line as a record
in a separate window. Only non-empty fields
are shown. 

Finally,  the  "Column  information..."  entry
gives access to  the table column description
window. 

Column information 

The column description panel accessible either via the measurement contextual menu or via the
main "Catalogue" menu displays in the form of a table all the information specific to each column:
its  description,  its  unit,  its  data  type,  its  UCD,  cell  size,  display  precision,  .....  Some  of  this
information can be modified.
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The column entitled "Visible" allows you to select the columns that will be displayed or hidden in
the table of measurements. 

The column named "Ref" is used to identify the columns (and its format) used by Aladin to extract
the  coordinates  (RA,  DE,  GLON, GLAT,  ELON,  ELAT)  as  well  as  the  own motion  (PMRA,
PMDE) of the source associated with the measurement line. This mechanism will also be used to
identify the column providing a date associated with this source (JD, MJD, ISOTIME,  YEARS,
DATE). It is possible to manually modify this selection by clicking in the corresponding box. The
small contextual menu which then opens allows you to indicate the nature of this column. 

Note:  In the case of a table without spherical coordinate support, it may be possible to indicate
columns of image coordinates (X, Y) at the FITS (centre origin of the bottom-left pixel). 

The two buttons at the bottom left allow you to change the order in which the
columns appear in the measurements window. 

Independent window 

The measurement panel can be temporarily detached from the main window by clicking on the logo

at the bottom right . This method provides a larger workspace for the view and, on the other hand,
to work more easily on a larger number of measurements. Note that the Aladin measurement table
can  display  several  hundred  thousand  lines  without  any  problem.  The  reintegration  of  the
measurement window in its original place is simply done by clicking again on the same logo, or by
closing the window.

Source selections 

The source selection can be done either by menu, mouse or a search expression.

Menu selection

Menu: Edit => Select ...
Shortcut: Ctrl+A (all objects)
Script:  select ...

The main menu "Edit" offers a sub-menu for selecting all sources, i.e. all sources present in the
catalogue drawings in the stack. It is also possible to select only the sources of one or some specific
planes via the "Edit => select all objects in the selected planes" menu. You will first have to select
the planes from the stack (see 5.1.2).

Mouse selection

Mouse selection is the most common method. It allows you to choose sources according to their
positions in the view.

➢ To select a source simply click on it in the view;
➢ To select multiple sources it is necessary to enclose them in a selection rectangle. To do this,

click on an area without a source slightly above to the left of the first source to be selected,
then  while  holding down the  mouse  button,  extend the  selection  by moving the  mouse
pointer downwards to the right. During this operation, a rectangle shows the selection area
in the view. When you release the mouse button, all sources within the rectangle will be
selected;

➢ To add sources to a first selection, proceed as before, but hold down the Shift key.
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Selection by search expression   

Menu: Catalog => Search in the loaded catalogs ...
Shortcut: Ctrl+F
Script: search ...

Aladin offers a powerful method for selecting sources based on their measurement values. To do
this, it is necessary to enter a search expression in the small "Search" box located just above the
right-hand side of the measurements panel.

When the search expression is validated by pressing the "Enter" key, all sources, for which one of
the measurements meets  the search expression,  are selected.  Only the sources of the  activated
catalogue  plans  will  be  concerned  (see  5.1.2 -  Activating  a  plan  in  the  stack).  If  the  search
expression is preceded by a '+' character, the sources to be selected will be added to the current
selection. Conversely, the presence of the '-' character at the beginning of the search expression will
lead to the deselection of the sources concerned among the sources previously selected, i.e. it will
make them disappear from the table of measurements.

The search expression follows a simple and efficient syntax. It can be:
➢ a text string;
➢ possibly including wildcards: '?'. (any character), '*' (any sequence of characters);
➢ possibly preceded by a column name and a test operator (=, !=, <, >, <=, >=) to restrict the 

search to a particular column;

Additionnally:
➢ the column name can include wildcards (' ?' or '*');
➢ the column name can be framed by two vertical bars '|' to indicate the absolute value;
➢ there is no distinction between upper and lower case letters either for the column name or

for the value. 

Note: For convenience, searching for a simple text string without specifying a particular column is
always considered as a sub-string to be searched. For example, a search for "gal" will result in
"*gal*".

A few examples:
➢ Star sources whose measurements include the word "star".
➢ otype=uv sources whose "otype" column has the value "uv".
➢ mag*>=12 first  column whose name starts  with "mag",  the numerical  value must  be

greater than or equal to 12
➢ |pm*|<5 Same principle as above but only the absolute value is taken into account.
➢ type!=g* "type" column whose values do not begin with the letter “g”.
➢ bmag!=""  "bmag" column not empty

Deselection   

Menu: Edit => Unselect objects ...
Shortcut: Ctrl+U
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➢ To deselect a source from a previous selection, click on the source while holding down the
Shift  key.  
Alternatively click on its line in the measurement window and then use the "Deselect this
source" or Shift-Click contextual menu.

➢ To deselect all the sources - this is equivalent to "cleaning" the measurement table - simply
click in the view anywhere outside any source or use the  "Edit => deselect all sources"
menu.

Tip: To avoid accidentally "losing" a selection, you can "tick" the sources in your table so that you
can reselect them later (see paragraph below).

Counters

The ratio of the number of selected sources (i.e. whose measurements are displayed) to the total
number of sources appears in the counter at the bottom right of the Aladin window.

Navigation in the measures 

The exploration of the measurements, and in particular the quick visualization of the associated
source, is done by selecting a particular line in the table of measurements. The selected line appears
on a blue background " fixed on the line " even if the mouse is not on it.

The selection of a line of measurements is done either manually with the mouse or by a search
expression.

Selection of a measurement line with the mouse

Mouse selection is made either in the measurements panel by a simple mouse click (outside a web
link or button) or in the view by clicking on a selected source (green square). This causes the cross-
hairs (magenta cross) to be moved to the corresponding source. And if the selection was made via
the table by double-clicking, the view is automatically centred on the source (unless the view has
been "locked" – see 5.1.4).

Selecting a measurement line via an expression   

The box used to select sources also allows you to select a particular line of measurements. Thus
entering an expression - WITHOUT performing validation (without pressing Enter) - and using
the two arrows to the right of the input box allows you to select the next/previous line of
measurements  corresponding to the expression.  The "UP arrow" and  "DOWN arrow"
keys, or the mouse wheel, can also be used to move to the next or previous measurement,
respectively. As with the mouse selection, the view is automatically centred on the corresponding
source. If the expression is empty, the next or previous line is simply selected.

Browsing of sources and measurements of a plan

It is possible to browse all the  measurements of a plan  by using the same mechanism of the two
arrows described in the previous paragraph. Open the contextual menu by right-clicking on the

42



name of  the  plan  in  the  stack  and choose  the  "Browse  the  plane sources"  menu.  The view is
automatically refocused on the object corresponding to the current measurement line.

Deselection

Deselecting the line is done by a simple click in the measurement panel (outside a web link or
button).

Inhibited behaviours

When a measurement line is selected, some automatic behaviours are inhibited:
➢ The header of the measurement panel remains the one associated with the selected line even

if  the  mouse  moves  outside  the  line  in  question  (this  allows  sorting  on  this  table,  for
example);

➢ Moving the mouse, in the view, over the other selected sources will no longer scroll the
associated measurements.

Measure check box 

Menu: Edit => Tag ..., UnTag ...
Contextual menu: Tag..., Untag these sources...
Script: tag ... untag ...

A small coloured box appears to the left of each line of measurements. It not only
allows you to identify the original plan of the data by the colour code, but also to
"tag" some lines and, therefore, the corresponding sources, so that you can easily
find them again later. 

Two menus allow you to manipulate the "tagged" sources:
➢ The menu that appears when you click on the pin in the header of the tag column;
➢ The main menu "Edit".

In the view, the sources whose lines of measurement are  tagged appear with a magenta square
instead of the usual green square.

Add/calculate a new column

Aladin offers the possibility to add a new column of values. This operation is described in detail in
section 5.13. 

5.2 The server selector
Menu: File => Open server selector ...
Shortcut: Ctrl+L
Script: get ..., load ...

As  a  complement  to  the  data  collection  tree,  Aladin  provides  direct  access  to  certain  forms
dedicated to specific servers. This is the "server selector" window. 
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This window consists of several query forms that can be selected using tabs. The tabs on the left
side of the window are for image servers, the tabs on the right side are for tabular data servers.

These tabs and forms may evolve over time as new possibilities are offered by the astronomical
community. 

5.2.1 Entering information 
Most of these forms require the entry of at least two elements essential for a cone query: a position
and a radius.

The position can be either an astronomical object identifier resolved by the Sesame mechanism of
the CDS (search in Simbad + NED + some large catalogues), or astronomical coordinates expressed
in the current reference frame (see. 5.1.7).

The radius corresponds to the radius of the cone query on the sky. This value can be followed by a
unit ("°", " ' " " " or " deg ", " arcmin ", " arcsec "). The default unit is the arc minute. It is also
possible to specify a rectangular area using the following syntax: W x H where W is the width of
the rectangle in right ascension and H is the height of the rectangle in declination. These two values
can be followed by a unit.  If  the queried server only supports  cone (resp.  rectangle)  querying,
Aladin will always choose an area that completely covers the designated field (encompassing circle,
resp. encompassing rectangle).

Automatic entry

In the current form, the position and radius are automatically filled in according to the previously
loaded data in order to cover the same field on the sky. It is also possible to explicitly designate an
area of the sky on an image that has already been loaded by means of the "target" button  that
appears  behind  the  position  input  field.  Aladin  invites  you  to  designate  the  area  by
clicking/dragging/releasing in the view.

44



When switching from one form to another via the tabs, the values indicated in the first form will be
retained in the second form.

5.2.2 List and tree 
Some servers require two steps to load the data: first to designate the area of the sky, then to select
from the available images or catalogues those you wish to load. In the second step, Aladin displays
the available data in the form of a list or tree. This list/tree has many functions:
➢ Moving the mouse over an item displays the corresponding field(s) of view in the main window;
➢ When the data is in the form of a tree, a right click brings up a sub-menu to control the tree;
➢ When the data is in list form, it is possible to sort the data by clicking on the column headings; 
➢ Clicking on an item displays the information relating to this data as well as certain specific

query parameters;
➢ Each item is preceded by a checkbox which allows you to designate several items to be loaded.

These  boxes  can  be  checked  either
manually or by clicking in the view to
designate  only  those  elements  that
explicitly contain the clicked position.
The  "Reset.  "button  allows  you  to
deselect  all  the  checkboxes.  The  "
Clear " button deletes the list / tree.

5.2.3 Some specific forms 

"File" - Local access or by URL. 

This form allows you to upload personal data, either via local files or via a web address (url). This
data has to be compatible with one of format supported by Aladin (see 8.1). The "Browse" button
allows you to navigate through the file selector of your operating system in order to identify the
concerned file.

Tip: Local data can also be loaded by clicking and dragging a file icon from a window on your
desktop or file manager into the Aladin window. The same applies to images or links displayed in a
web browser.

Tip: In the case of a local directory name, Aladin will explore the entire contents of the directory
and its sub-directories and build a tree of available data. It will create a file named ".aladin_idha"
which  will  allow  him  to  quickly  reload  this  description  for
another use.

  "FOV" - The instrumental Fields of View 

 This form provides access to a description list of
instrumental  fields  of  view  ("FoV")  of  a  large  number  of
telescopes. These fields can be superimposed on the images to
prepare  an  observation  mission.  They  can  be  moved  or  even
rotated by means of a mouse selection.

It is possible to define one's own instrument fields in the form of
an  XML  file.  The  syntax  description  and  some  examples  can  be  found  at
http://aladin.  cds.unistra  .fr/java/FAQ.htx#FoV  .
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  "TAP" - Access to TAP-
compatible servers 

This tab provides access to servers that
support the Table Access Protocol (TAP).
Activating  this  tab  displays  a  list  of
servers pre-selected by the CDS, as well
as  the  exhaustive  list  of  compatible
servers. Although this query mode is also
available  via  the collection tree,  it  may
be more convenient to use this tab if you
wish  to  query  a  particular  TAP server.
Once the server has been selected, a TAP
query form is proposed (see 5.3).

  "SkyView - The HEASARC/NASA image server 

SkyView is an image generation service managed by HEASARC/NASA. It provides images from a
very large number of reference surveys, dynamically resampled in a projection chosen by the user. 

  "Gaia" - The astrometric reference catalogue 

Gaia is  THE reference astrometric  catalogue from the  European mission  of  the same name.  It
contains  almost  two billion  sources  with  an  unrivalled  astrometric  accuracy.  Being part  of  the
distribution consortium of this catalogue (CU9), the CDS proposes this specific form. 

"SkyBot" - Objects of the solar system (except planets) 

The "SkyBot" tab opens a form for accessing objects in the solar system (other than planets). The
Institute  of  Celestial  Mechanics  of  Paris  (IMCCE)  provides  Aladin  with  its  database  of
ephemerides,  which  allows  you  to
find,  with  excellent  precision,  the
asteroids  and  other  objects  of  the
solar system present in your image
according  to  the  epoch  of  your
image.

The date field is automatically filled
in  according  to  the  epoque of  the
current image.

Note:  the  time  indicated  in  the
header of the image is not always very precise, hence possible positioning errors. In this case, you
will need to enter the date manually.
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On the other hand, it is possible to enter the name of an asteroid or comet in the position field so
that SkyBot replaces it with its celestial position on the date mentioned. To do this, press the button
"Get coordinates for this object + epoch".

  "VO" - Generic access to the VO 

The VO tab offers a series of generic forms specific to each of the protocols defined by the VO - the
Virtual Observatory. As long as you know the address of a specific server compatible with one of
the VO protocols, you will be able to query it directly.

5.2.4 Adding a personal server
The "server selector" window can be adapted to your own servers. Thus, it is possible to define a
personal server that will add its own tab/form. To do this, it is necessary to create a small file with
information such as name, description, web address, various parameters, and load it into Aladin like
any other file. In order to retrieve this form each time it is launched, it may be necessary to indicate
it in the Aladin start command line:

java -jar Aladin.jar yourFile

Example of a   description file:   

%ActionName MyServer
%Aladin.Label Test
%Description This is an example of a server
%URL  http://mon.site.web//base/req?yy=$1&xx=$2
%Param.Description $1=Parameter 1
%Param.Description $2=Parameter 2
%ResultDataType Mime(image/fits)

The complete syntax is described in Aladin's FAQ (  http://aladin.  cds.unistra  .fr/java/FAQ.html#Glu  ).

Tip: Such a record can be copied/pasted without going through a file. 

5.3 Criteria-based query forms
Some data providers distribute their collections through a particular IVOA protocol called TAP for
"Table Access Protocol". This query protocol allows the user to write and then submit a query in a
syntax referring to any field in the server database structure. These queries must follow the ADQL
(Astronomical Data Query Language) syntax defined by the IVOA, which is a derivative of the
SQL language6.

Although very powerful and versatile, such a request is difficult to build. This is why Aladin offers
two types of forms to help you write and then submit such a request. These are offered to you from
the "access window" that appears when you click on the name of a collection in the collections tree
(see 1). The simplified form will be called if you select the "custom" selector, while the generic TAP
form is associated with the "by TAP criteria" selector. 

6 http://www.ivoa.net/documents/latest/ADQL.html
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Customised TAP form

The simplified TAP form has been
"customised"  beforehand  by  the
CDS to  allow you to  constrain  a
predefined list  of criteria,  relating
to  one  or  more  tables  in  the
database that you wish to query.

This form is easy to use but does
not allow you to choose any other
criteria than those selected by the
SSC.  The  ADQL  query
corresponding  to  your  selections
appears at the bottom of the form,
and  if  you  wish,  you  can  edit  it
directly and then submit it.

Generic TAP form (by criteria)

The generic TAP form sets out all the possible tables and query criteria. You will need to select the
table to be queried unless it has been automatically pre-selected. Then, using the control buttons,

add the constraints you want on each of the
available fields. The question mark at the top
of the form opens a new window displaying
the  descriptions  and  other  metadata
associated with each field in each table. Such
a  form  requires  a  good  knowledge  of  the
internal structure of the Supplier's database.

As  with  the  simplified  form,  the
corresponding ADQL query is  displayed in
the bottom panel. You can edit it manually if
you wish, then all you have to do is submit
your request.

Let's now take a look at the filtering of the
collection tree.
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5.4 Filtering the collection tree 

Icon:  
Menu: File => Filter on data collections ...

The collection  tree  presents  several  tens  of  thousands  of  collections.  In  addition  to  the  simple
keyword filter presented in section 5.1.1, Aladin offers a sophisticated and fast mechanism to view
only those collections that meet certain criteria. These can be of different natures: temporal, spatial,
in flow, or on any characteristic that will have been associated with a collection.

The filter window is opened by clicking on the icon to the right of the
selector at the bottom of the tree, or by means of the menu "File ->
Filter on data collections...". 
This window has a central part with 4 tabs, each of them grouping the selectors and input fields
specific to a category of constraints:

➢ Global constraints;
➢ Specific to the catalogues;
➢ Coverage;
➢ Technical.

The  lower  part  of  the  window  displays  the
logical  expression  corresponding  to  the
constraints  entered  through  the  tabs.  And  just
below, in green color, the number of collections
selected by the filtering rule and now displayed
in the collections tree.

The  upper  part  of  the  window  allows  you  to
name the filtering thus created and save it  for
later use, possibly in a future session of Aladin.
From now on it will be available in the selector
below the tree. 

Properties and coverings 

Aladin's  filtering  system  uses  the  properties
associated  with  each  of  the  tree's  collections.
These properties are represented in the form of a list of predefined keywords to which the provider
of the collection associated one or more numerical values, or in a specific or free vocabulary. These

properties  can  be  viewed  by  displaying  the  "access  window"
associated with the selected collection, then clicking on the icon 

.

For spatial filtering, Aladin uses all the MOCs, i.e.  the covers of
each collection on the celestial sphere (see 4).

Restriction  of  use:  The  collections  are  distributed by many data
providers around the world. Even if they are working to describe
their  collections  in  common  IVOA standards,  there  are  some
differences mainly on the keywords to be filled in or not, and on

49



the vocabulary to be used for such or such property. This heterogeneity on metadata must be taken
into account when developing a filtering rule, and the results obtained are only a reflection of the
quality  of  the  initial  descriptions.  On  the  other  hand,  coverage  (MOC)  is  not  systematically
provided  by  data  providers.  These  collections  can  therefore  not  be  filtered  spatially  and/or
temporally.

Technical note: 7Aladin's filtering is based on a library developed by the CDS, installed on the one
hand in the Aladin client itself and on the other hand in a remote server: the MocServer . The joint
use of these two elements offers a powerful, flexible and very fast filtering system. Some technical
details on this mechanism are provided in the section 8.3 at the end of the document.

Syntax of collection filtering rules

As an alternative to the selectors in the filter form, you can directly enter a filter rule in its internal
form, i.e. a string describing a series of conditions. Thus, a basic rule is a condition to be fulfilled in
the form of a "keyword = value" expression. This string can be directly passed in the "Select" field
under the collection tree, or in the lower part of the filter form.

Example: ID = CDS/P/DSS2/colour

In this condition, the keyword is nothing more than the name of a field in the properties associated
with each collection. It can also be a comma-separated list. The wildcards " * " (any sequence of
characters) and "? " (any character) can be included. In the same way the value can be single, or
multiple (separated by commas), and can also include wildcards. An interval is represented by its
two bounds separated by two consecutive dots (..). Finally the condition is not limited to equality
(=) but can also be difference (!=) and comparisons on numerical values or dates (>,<,>=, <=).

Several simultaneous conditions can be organised using the logical operators AND (&&), OR (||),
EXCEPT (&!) and parentheses to ensure the order of the logical operations.

Examples:
➢ ID = CDS*,ESA: with ID begins with "CDS" or "ESA".
➢ obs_* = *NASA*: where one of the fields beginning with "obs_" contains the word 

"NASA".
➢ bib_year = 1996 .. 2000: year of publication between 1996 and 2000 inclusive
➢ moc_order < 3 && (moc_order > 10 || moc_skyfraction = 1)
➢ hips_builder = !*: whose hips_builder field is empty
➢ obs_regime = X-ray,UV &! ID = CDS*: whose obs_regime is "X-ray" or 

"UV", unless the ID starts with "CDS".

Note: When the field is not filled in, the collection is discarded with the notable exception of the
condition " = !* " i.e. " empty ".

5.5 The pixel dynamics manager 

Button: pixel  
Menu: Image => Pixel contrast & map ...
Shortcut: Ctrl+M

7 http://alasky.cds.unistra.fr/MocServer/query  
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Type of images: HiPS and classic images
Script: cm

Aladin  uses  a  specific  algorithm  to  optimize  the  contrast  of  astronomical  images.  These  are
characterised by a dynamic range of  pixel  values  that  is  often very wide,  and sometimes with
outliers (edge of the detector, saturation, unknown values...). However, the "monochrome" (or false
colour) visual rendering can generally only take 256 values on your graphics card. Therefore Aladin
samples the pixels in order to apply a threshold: all pixel values below the low threshold will be
displayed  in  white,  those  above  the  high  threshold  in  black,  and  intermediate  values  will  be
converted between 0 and 255. Aladin's "automatic thresholding" usually gives a good contrast on
"interesting" pixels.

The 256 pixel values can be displayed either in grayscale, positive or negative, or with a colour
table that matches each pixel value to a particular colour.

It is possible, however, that the "interesting" pixels are not the ones you are interested in, or that the
automatic thresholding algorithm is not well adapted to the characteristics of the images you are
viewing. To manually adjust the pixel dynamics, you can use the menu " Image => Pixel contrast
& map ... ", or more directly the " pixel " button accessible in the toolbar.

The Pixel Dynamics window can be read from top to bottom as follows:
➢ The top bar shows the totality  of  the pixel  values present  in  the image.  The blue zone

corresponds to the range of values chosen
by Aladin to be displayed;

➢ The  middle  rectangle  displays  the
histogram  of  the  distribution  of  the
selected pixels and overprints the transfer
function  applied  to  convert  the  selected
range of values to 256 values;

➢ Finally, the bar at the bottom presents the
table of colours chosen to represent the
256 calculated values.

Example:  The  pixel  values  shown  here  are
between  0.1668 and  3.752,  the  selected  range
includes pixels between 0.4654 and 3.444 which
are converted into 256 grey levels using a linear
transfer function.

Several  buttons,  selector  and  hotspots  allow  you  to  adjust  the  settings  of  the  pixel  rendering
algorithm. 

Contrast and brightness adjustment 

➢  "Intuitively":  The  simplest  method  uses  the  technique
implemented in the "DS9" software: using the mouse, click
and hold down the right button and then move the mouse
over the surface of the view, you will be able to intuitively
adjust  both  contrast  and  brightness  depending  on  the
position of the mouse within the view.
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➢ "Based on specific rules": In the pixel control window, you can initially adjust the values of
the  selected  range either  by  manually  entering  (and validating  by the  return key)  these
values in the numeric fields above the pixel histogram, or by clicking and dragging on the
right or left limits of the range of values (top bar). This action forces Aladin to read back all
the pixels of the image file. This may take a few tenths of a second or more, depending on
the size of the image. An alternative, much faster option is to play only with the conversion
method of the selected range, without changing the limits. This can be done by first using
the transfer function . By linear default, it can be
replaced by one of the following functions: Asinh,
Log,  Sqrt,  Pow2.  Then,  in  order  to  refine  your
function,  a  second  operation,  linear  on  two
segments, can be applied by composition to your
first  choice.  To do this  you must  play on the 3
control  triangles  placed  under  the  histogram  in
order to determine the respective slopes of the two
segments. 

Tip: The manual research for the range of "interesting" pixels to be displayed can be tedious, and
can vary from one region to another in the same image (centre of a star, background of the sky). The
"Local  cut" button asks  Aladin to  apply his  thresholding algorithm only around the
current position of the reticle, and on a radius of one sixth of the current view. So to
adjust the contrast on a specific star or galaxy, simply click on it, adjust the zoom and
then activate the "Local cut" button. 

Note:  This  automatic  thresholding  action  is  always  applied  when  the  "hdr"  icon  is
activated (under the view). 

Colour tables 

Aladin has some colour tables common in astronomy. These can not only be adjusted via the control
of the transfer function as described above, but also reversed.

Tip: Use  the "CM on view" button to display the colour table overlay in the view. Its size and
position can be changed by clicking on the colour table and then acting on the control
handles. 

Here is the list of colour tables with a simple linear transfer function and their rendering in normal
and reverse mode:

➢ Gray:

➢ BB: 
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➢ A: 

➢ Stern:

➢ Rainbow:

➢ Eosb: 

➢ Fire: 

➢ Cubhlx: 

➢ Polar: 

Note: IDL users can also dynamically load an IDL colour table via the IDL-Aladin library (see 7.5).

Quick pixel scanning

By hovering  over  the  colour  table  bar  with  the  mouse  pointer,
Aladin will temporarily use a particular colour table to highlight the
positions of the corresponding pixels in the image. The image will be
displayed in grey level, and the pixels concerned in cyan.

Special images, special cases

In the case of a true colour image, or a cube of images, the window is
adapted according to the nature of the pixels.

Colour image   

Aladin can manipulate images in "real"
colours  (colour  composition -  see  5.15,
JPEG , PNG or colour FITS images). In
this  case,  there  is  no  automatic
thresholding  and  the  dynamic  control
window shows 3 histograms one above
the  other,  with  their  control  sliders,
corresponding to the distribution of pixel
values in the 3 components Red, Green
and  Blue.  Each  histogram  has  its  3
control  sliders  as  for  a  classic  image.
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Holding down the  Shift  key while moving a slider synchronizes the sliders of the 2 other colour
components, allowing an adjustment to be made simultaneously on the 3 components.

C  ubes of images   

Aladin can manipulate picture cubes (see 5.16- image associations, or FITS cubes). In this case, the
histogram of the pixel distribution only concerns the image currently being displayed. If the cube is
being scrolled,  the  histogram will  dynamically  change according to  the  current  image.  All  the
possibilities for adjusting the pixel dynamics are the same as for a simple image. In the case of very
large cubes (several hundred megabytes), operations to modify the original threshold may take a
few seconds for the result to be visible on all the images making up the cube.

Multi-images   

Aladin can manipulate images from multi-CCD sensors. These will be displayed simultaneously in
the view,  but  will  not  necessarily  have  the same contrast  adjustment.  To apply the  same pixel
adjustment function to all CCD sensors, use the 'Apply to selected images' button at the bottom of
the pixel window.

HiPS image

In the case of HiPS images,  the pixels can be viewed either in "  Preview "  mode or in "  Full
Dynamic " mode. Pixel dynamics adjustments will only be fully possible in the latter mode.

5.6 Contour generator

Button: Cont  
Menu: Overlay => Contour plot...
Type of images:  HiPS and classic images
Script: contour ...

Aladin has a contour extraction tool to generate isocontours of an
image. The menu "Overlay => Contour plot..."  opens a control
window allowing you to adjust the number of isophotes desired
as well as their pixel level in relation to the histogram of pixel
distributions  present  in  the  image.  It  is  possible  to  smooth  or
reduce the image noise, or to reduce the extraction to the portion
of the image visible in the view.

The contours will be stored in a plane of the stack, which can be
superimposed on the original image, but  also on other images
(usage of celestial coordinates). This property makes it easy to
compare  two images  that  do not,  for  example,  have  the same
wavelength.
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Tip: The properties window associated with a contour plane
(menu:  Edit  =>  Properties)  allows  you  to  adjust  a
posteriori the levels and the colour of each contour.

Restriction  of  use:  contour  extraction  is  possible  on  a
progressive  survey  (HiPS),  but  it  will  be  automatically
flanged  to  the  current  field  of  view.  Internally,  the

generation algorithm does not work on the HEALPix pixels, but on a sub-image extracted from the
HiPS survey (see 5.1.5- The cutting tool ).

5.7 Calculators 

Aladin has several tools to help you in your calculations, whether it be for current numerical values,
pixel values or spherical coordinates. Aladin also offers a conversion tool for the various units.

5.7.1 Algebraic calculation by script command 
Menu: Tool => Calculator...
Script: = expression

For any classical algebraic calculation, you can directly enter your expression in the form of a script
command.  It must  begin  with  the  character  "="  like  a  spreadsheet  formula.  All  the  classical
operators, parentheses, and common mathematical functions are supported. Some functions specific
to astronomy are also supported: 

x,+,*,/,%,^ addition, subtraction, multiplication, division, modulo, power
exp(x) Euler's number 'e' raised to the power of x
ln(x) the natural logarithm (base 'e') of x
log(x) the base 10 logarithm of x
sqrt(x) the correctly rounded positive square root of x
ceil(x) the largest (closest to positive infinity) integer value
floor(x) the smallest (closest to negative infinity) integer value
round(x) the value of the argument rounded to the nearest integer
abs(x) the absolute value of the argument
sin(x) trigonometric sine of an angle (x in radians)
cos(x) trigonometric cosine of an angle (x in radians)
tan(x) trigonometric tangent of an angle (x in degrees)
asin(x) the arc sine of a value (result in radians)
acos(x) the arc cosine of a value (result in radians)
atan(x) the arc tangent of a value (result in radians)
sinh(x) the hyperbolic sine of x
cosh(x) the hyperbolic cosine of x
tanh(x) the hyperbolic tangent of x
sind,cosd,tand trigonometric functions of an angle (x in degrees)
asind,acosd,atad the arc trigonometric functions (result in degrees)
rad2deg(a) the measurement of the angle a in radians
deg2rad(a) the measurement of the angle a in degrees
min(x,y) the smaller of x and y
max(x,y) the larger of x and y
atan2(x,y) the angle (in radians) corresponding to x,y in Cartesian coordinates
atan2d(x,y) the angle (in degrees) corresponding to x,y in Cartesian coordinates
dist(x1,y1,x2,y2) Cartesian distance between x1,y1 and x2,y2
skydist(ra1,de1,ra2,de2) spherical distance (coord in degrees or sexa with ':' as separator

Examples: 
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= 3*8
= 1024 * (132E-7 +1/32.2)
= -skydist(05:34:43.68,+21:59:28.1,184.50849,-05.79883)*-60 -sin ( -

round( 100+1e-03)%(3*2) + -cos(32.2+8^(7-5*max(3.1/8.7) ) ) * -(6-
2E+5)

Tip: The "=" character can also be inserted after the algebraic expression rather than before.

5.7.2 Conversion by script command 
Script:  convert xxx unit1 into unit2

Aladin also integrates a conversion library8 taking into account most of the usual physical units.
This library is used through the "convert" script command, which can be entered directly in the
command banner.

The syntax is: convert xxx unit1 into unit2.

The value is usually a scalar, or an algebraic expression,  or possibly a date,  or even a number
expressed in sexagesimal (longitude or latitude of a coordinate).

The units must be one of those in the table below, or a combination of units using conventional
operators (e.g. km/s). They may be prefixed by a letter specifying a multiple or sub-multiple (e.g.
mHz). The list of these multiples is given in the second table.

solMass solar mass 
gauss Gauss(10-4T) 
pi pi(=3.14...)
ph photon 
pc parsec 
yr year 
µ0 (magnetic constant) 
geoMass Earth mass 
Ry Rydberg(13.6eV) 
JD Julian Date 
\h hbar(Planck constant)
inch inch 
Hz Herz 
Angstrom Angstrom(0.1nm) 
Mgeo Earth mass 
rad radian 
"d:m:s" degree arcminute arcsecond (sexagesimal 
angle from degree)
erg erg(10-7J) 
mas milli-second of arc 
"month" month 
eV electron-Volt 
"day" Day of month number
mag magnitude 
"datime" Fully qualified date/time (ISO-8601)
"date" Fully qualified date
"YYYYMMDD" Fully qualified date (without separator)
"h:m" hour minutes (sexagesimal time from hours)
muB (Bohr magneton) 
mp mp(proton_mass) 
Å Angstrom(0.1nm) 
ct count 

me me(electron_mass) 
mu0 (magnetic constant) 
"hhmmss" hour minutes seconds (sexagesimal time 
without separator)
Pa Pascal 
cal calorie 
cd candela(lumen/sr) 
lx lux(lm/m2) 
jovMass Jupiter mass 
min minute 
lm lumen 
byte byte(8bits) 
solRad solar radius 
alpha (constant fine structure) 
arcmin minute of arc 
uas micro-second of arc 
"m:s" minutes seconds (sexagesimal time from 
minutes)
"h:m:s" hour minutes seconds (sexagesimal time 
from hours)
---
au astronomical unit 
kg kilogram 
sec second (use 's')
al light-year 
bar bar(10+5Pa) 
Lsun solar luminosity 
mmHg mercury_mm 
"MM/yy" Month/Year(from 2000 when yy<50)
u atomic mass unit 
t tone 
s second 

8 This library was developed by the CDS to handle the physical quantities of the catalogues managed by the VizieR ser-
vice (  http://vizier.  cds.unistra  .fr/doc/catstd.htx  ).
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MJD Modified Julian Date (JD-2400000.5) 
m metre 
l litre 
k k(Boltzmann) 
h hour 
Wb Weber(V.s) 
solLum solar luminosity 
g gram 
arcsec second of arc 
e e(electron_charge) 
d day 
c c(speed_of_light)
a year 
dyn dyne(10-5N) 
sr steradian 
? hbar(Planck constant)
W Watt 
V Volt 
T Tesla 
S Siemens(A/V) 
R R(gas_constant) 
Sun Solar unit 
pix pixel 
N Newton 
K Kelvin 
bit binary information unit 
J Joule 

H Henry 
G G(constant gravity)
eps0 (electric constant) 
F Farad 
D Debye (dipole)
barn barn(10-28m2) 
C Coulomb 
"MM/YY" Month/Year(from 1900)
deg degree 
Rsun solar radius 
A Ampere 
a0 (Bohr radius) 
? pi(=3.14...)
mol mole 
µas micro-second of arc 
hr hour(use 'h') 
atm atmosphere 
Mjup Jupiter mass 
% percent
"ddmmss" degree arcminute arcsecond (sexagesimal 
angle without separator)
degF Fahrenheit 
Jy Jansky(10-26W/m2/Hz) 
degC Celsius 
Ohm Ohm(V/A) 
lyr light-year (c*yr) 
Msun solar mass

  Symbol Explanation Value
  d deci 10–1 
  c centi 10–2 
  m milli 10–3 
  u micro (µ) 10–6 
  n nano 10–9 

  p pico 10–12
  f femto 10–15
  a atto 10–18
  z zepto 10–21
  y yocto 10–24

     

 

Symbol Explanation Value
  da deca 10 
  h hecto 102 

  k kilo 103 

  M mega 106 

  G giga 109 

  T tera 1012 

  P peta 1015 

  E exa 1018 

  Z zetta 1021 

  Y yotta 1024

Examples: 
convert 1/10m into nm => 1.0E8 nm 
convert 2a into d => 730.5 d
convert 20011210 "YYYYYMMDD" into MJD => 52253.0 MJD
convert 10:10:8 "d:m:s" into deg => 10.1688888888889 deg

5.7.3 Pixel calculator 
Calculations on pixel values are common in
astronomy  because,  most  of  the  times,
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images use a transformation function: the internal coding in the form of a real or integer (raw), will
be multiplied  by a  constant  factor  (keyword FITS BSCALE),  then the  result  will  be added to
another constant (keyword FITS BZERO). Therefore, the conversion from the coding value to the
represented physical value, follows the rule: value = BZERO + BSCALE * raw. 
On the other hand, for display, this physical pixel value will have to be converted into a colour (or
greyscale) table index between 0 and 255, or even 1 and 255 if channel 0 is used for transparency.
This conversion depends on the choices made to control the colour table (transfer function, range of
physical values of the pixels to be displayed) (see 5.5).

Both of  these conversion operations can be managed in the pixel  calculator.  This  appears  in a
window via the menu "Tool -> Pixel calculator".

This form can be used freely by manually assigning the constants BZERO and BSCALE and the
value of a pixel.  These values,  the parameters  of the colour  table,  and the pixel  value will  be
automatically filled in if you click in an image displayed in the view.

5.7.4 Coordinate calculator 
As with pixels, calculations relating to astronomical coordinates are very common: conversions of
the  sexagesimal  or  decimal  representation,  modification of  spatial  referential  (e.g.  conversion
B1875  to  ICRS),  taking  into
account  the  time  of
observation  in  relation  to  the
time  of  display  with
knowledge  of  the  proper
motion  and/or  radial  velocity,
etc.  These calculations can be
complex.  Aladin  offers  you  a
"coordinate  calculator"
accessible  through  the  menu
"Tool  ->  Coordinate
calculator".

You can use this calculator by directly entering the coordinates and other position parameters, then
validate with "Enter" to obtain the same coordinates in other systems and times. You can also click
in the view, or even in the measurement window, to take into account the position under the mouse.
In the case of catalogue measurements, if the catalogue has its own motion and/or radial velocity
information, these parameters will also be filled in and used.

5.7.5 Time calculator
Aladin  provides  a  small  utility  for  converting  dates.  It  is
accessible through the menu "Tools → Time Calculator". This
tool  allows  you  to  obtain  the  equivalences  between  a  date
expressed  in  ISO  format  (YYYY-MM-DDTHH:MM:SS),  and  the
correspondences in Julian Days (JD), in Modified Julian Days
(MJD), in decimal Julian years, or in decimal Besselian years.
Just fill in one of the fields, and validate with the "Enter" key to
obtain the equivalences in the other systems.
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5.8 Catalogue Filter Manager 

Button: Filter  
Menu: Catalog => Create a filter...
Data type: HiPS catalogues and classic catalogues
Script: filter ...

Catalogue filtering in Aladin is a powerful tool for an "intelligently" viewing of the sources.

Note: Catalogue filters should not be confused with collection tree filtering.

Default behaviour (without filter)

By  default,  Aladin  represents  the  sources,  using  graphic
symbols, all identical for a given catalogue plan (colour and
shape). The shape is only dependent on the number of sources
(smaller symbols for dense catalogues). The colour and shape
can be modified a  posteriori  by using the properties  attached to  the catalogue layer  ("Edit  =>
Properties" menu), the size using the "size" slider under the stack.

However, it  may be interesting to constrain shape and colour based on the measurement values
associated with each source. To do this it is necessary to use what Aladin calls "a filter".

Filter definition 

For Aladin, a filter will be applied to one or more catalogue plans in order to modify the way the
graphic symbols are drawn in the view. This is one or more rules that will tell Aladin how to draw
the  sources  according  to  the  values  present  in  the
measurements of each source. Thus it will be possible
to  draw  circles  proportional  to  the  magnitude,  error
ellipses on the position, arrows whose orientation and
size depend on the values of its movement...

Representation of the filter in the stack   

The filter is represented as a special plan in the stack
that applies to all catalogue plans below it.

Predefined filter 

Aladin offers some predefined filters that correspond to
the most common manipulations in astronomy. You can select them and apply them immediately via
the "Catalog => Predefined filters" menu.

On the other hand, it is often necessary to fine-tune the
filter constraints and to do this, you need to manually
create or edit your filter rules. This will be detailed in
the next section.
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 Filter generation

A filter is generated using the "Filter" button in the toolbar or
from the "Catalog => Create a filter" menu. Two modes are
available via tabs:

➢ The "beginner" mode, which is the same as using a
predefined filter (see above);

➢ The "expert" mode where you are in charge of editing
your own filtering rules.

The expert mode panel allows you to edit the filter rules in
the central edit box, and offers a range of editing aids:

➢ Many commented examples that can be used as a
basis for your own filters;

➢ Buttons to access the column references of the
catalogues currently loaded in Aladin;

➢ A button to access the graphic "actions" to be
implemented;

➢ Buttons to access the available mathematical
functions and physical units.

You can also reload a filter from a previously saved file.

Syntax 

To understand the syntax of a filter, let's start with the following example. Suppose you want to
display "object types", and only for bright sources. This filter can be written as follows:

${B}<18 { draw ${OTYPE}  }

Only lines with a value in column "B" (magnitude B) of smaller than 18 will be retained, and the
display will focus on the contents of the column "OTYPE" (type of object).

As we can see, a basic filter follows the following syntax:

un_test { une_action }

➢ The test is optional and if it is not available, all sources are concerned;
➢ It is possible to indicate several actions, separated by the character ';' or a line break;
➢ It is possible to have several consecutive "test{action}" groups, knowing that it is the action

associated with the first "true" test in the list that will be taken into account, the other lines
being ignored.

${class}="Star" {draw square}
${class}="Radio" {draw rhomb}
${class}="Galaxy" {draw more}

➢ Lines beginning with '#' are comments.
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The test

➢ The test uses the usual comparison operators (=, !=, <, >, >=, <=).
➢ It can contain parentheses and boolean operations AND (&&), OR (||), NOT (!).
➢ It can use mathematical functions (abs, cos, deg2rad, exp, ln, log, rad2deg, sin, sqrt, tan);

Example: Drawing of the sources according to the following expression:
log( abs(${Fi})/${Fx} ) > 44 { draw }

➢ It is necessary to use quotes (") for strings. Wildcards '?' and '*' are allowed;
➢ The "undefined(...)" operator is used to identify rows that do not have a value for a given

column.

Graphic actions

Two actions are possible:
➢ draw: to display a source;
➢ hide: rarely used, it allows to hide particular sources.

In the case of a "draw", the action can concern the shape and/or the colour of the line. The syntax is
as follows:

draw colour shape

The filter edit panel offers two buttons to quickly select the desired shape and/or colour.

       

The shape and colour functions can refer to columns and/or use arithmetic expressions.

Example: drawing red triangles:
{ draw red triangle }

Example: Ellipse plotting
{ draw ELLIPSE(0.5*${MajAxis},0.5*${MinAxis},${PosAng}) }
}
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Example: Drawing squares whose colour depends on the magnitude
{ draw RAINBOW(${magB}) square }

Special functions

➢ FILLCIRCLE: solid circle;
➢ FIXEDCIRCLE: Circle whose size is fixed (not subject to the zoom value of the view);
➢ PM: Arrow  whose  orientation  and  size  depend  on  the  two  angles  indicating  proper

movement;
➢ LINE: plotting of a segment, very useful to visualise the results of a correlation between 2

catalogues.

The CIRCLE, FILLCIRCLE and RAINBOW functions accept two optional parameters that provide
the minimum and maximum values used for tracing. Example:  draw CIRCLE(${A},1,10)
will  draw proportional  circles for the values in  column "A", the smallest  circle  having 1 pixel
radius, the largest circle 10 pixels.

If the "draw" action is on a string (ex:  draw "star") or a reference to a column (ex: draw $
{ObjectClass}), it will be the string or the value of the column that will be displayed.

Column name or UCD   

The reference to a column value is classically made by the name of the column thanks to the syntax
${COLUMN_NAME}. This method implies that the filter is more or less dedicated to a particular
catalogue since it is necessary to know explicitly the names of the columns. To write more generic
filters, for example taking into account the magnitude regardless of the column name given by the
author, Aladin uses UCDs.

UCDs, or Unified Content Descriptors, provide an independent characterisation of the columns in
the catalogue. Each column has been associated with a UCD which allows to know the physical
quantity represented by the column. For example a column with magnitudes will be labelled by the
UCD "pos.mag". The list of UCDs is maintained by an international committee and is available on
the IVOA website9. Most astronomy servers provide their catalogues in VOTable format already
annotated  with these UCDs.

When a filter rule uses a UCD, the syntax used is  $[UCD]. Wildcards '*' and '?' are allowed. For
example $[phot*] is the first column with a UCD that starts with 'phot', in other words, the first
column with magnitude measurements.

In summary, the reference to a column by its name is written with braces, the reference to a column
by its UCD with square brackets.

Example: Drawing a circle proportional to the magnitude
for all sources brighter than 12

$[phot*]<12 { draw circle(-$[phot*]}) }

9   http://www.ivoa.net/Documents/latest/UCDlistMaintenance.html  
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To simplify the entry of references to columns, the editing panel of a  filter  offers two buttons
"Columns" and "UCDs"  which allow to click in a list on the column name, respectively on the
UCD, so that the corresponding text is automatically written at the position of the cursor in the
editing window.

In  case  sources  are  selected  in  the  view,  and  thus  show their  measurements,  it  is  possible  to
designate a column by simply clicking on it in the measurements panel. To do this, it is necessary to
choose the "Point..." sub-menu when you click in "Columns" or "UCDs".

Physical units   

The  indication  of  physical  units  (e.g.  arcmin,  Jy...)  in  the  test  allows  you  to  avoid  manual
conversion for expressions using columns whose values are not expressed in the same unit. The
units can be composed as shown in the example below. This is a powerful function that allows you
to write very generic filters.

Example: Drawing a circle proportional to the flux in X (UCD: phot.flux;em.X-ray)
for all sources whose energy level is higher than the mentioned threshold.

$[phot.flux;em.X-ray]>10^-8 erg/m^2/s
{ draw circle($[phot.flux;em.X-ray]) }

Updating a filter

To find the editing window of a filter, select this filter in the stack and then display its properties via
the menu "Edit => Properties".

Scope of application of a filter 

In order to be applied, a filter must be activated (click on its logo in the
stack). By default, a filter is applied to all the catalogue plans below it in
the Aladin stack. On the other hand, if a filter is placed in a folder in the stack, it will only apply to
the catalogue drawings in this folder, even if this folder does not have the "local" property activated
(see 5.1.2).

Filter dedicated to a single catalogue plan 

Some servers offer a series of filters dedicated to their data
(Simbad , NED , Skybot ...). They appear in some data query
forms (see 5.2) like a drop-down list, at the end of the list of
query parameters.

A "dedicated" filter, if activated, does not appear in the stack
and  it  is  only  applied on the  catalogue  plan  concerned.  It
inhibits the action of any other generic filter  on that plane.  The
choice  or  activation  of  a  "dedicated"  filter  can  be  modified  a
posteriori via the "properties" associated with the plan (Edit menu
=> Properties...).  Via  the  "This  filter  on  the  stack  for  edition"
button, it is also possible to "transform" a "dedicated" filter into a
generic  filter  in  order  to  modify  it  and/or  apply  it  to  several
catalogue plans.
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Examples of generic filters 

Circles according to 
magnitude

{
 draw circle(-$ [phot.mag*])
}

Position ellipses
+
Default display

{
 draw ellipse(
  0.5*$ [phys.angSize.smajAxis],
  0.5*$ [phys.angSize.sminAxis],
  $[pos.posAng])
 draw
}

Blue squares for 
bright sources

$[phot.mag*]<17 {
 draw blue square
}

Different coloured 
symbols depending on
the class of the object

$[src.class]="Star
    {draw red square}
$[src.class]="Radio
    {draw blue rhomb}
$[src.class]="Galaxy"
    || $[src.class]="Seyfert"
    {draw green plus}

Proper motions

{
 draw pm(
    5*$ [pos.pm;pos.eq.ra],     
    5*$ [pos.pm;pos.eq.dec])
}

5.9 The "Automatic measurement" tool 
Menu: Tool => Auto-distance measurer

The  "automatic  distance  measurement"  tool  is
activated  via  the  "Tool"  menu.  When  this  tool  is
activated,  the  selection  of  two  catalogue  sources
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results in the temporary drawing of a segment between these two objects with the display of their
angular distance measurement.

Tip: To precisely determine the distance between two astronomical objects in an image, and not in a
catalogue, use the "phot"  tool and click on each of these objects beforehand so that Aladin can
calculate the barycentric centroid for each of them. Then select the two measurement points to see
the precise separation distance.

5.10 The "study" tool 

Button: study  
Menu: Tool => Simbad pointer

Tool => VizieR photometry pointer

Aladin relies on the CDS databases to examine the astronomical object pointed at by the mouse. If
the object  has  already been studied by the scientific  community additional  information on this
object  can  be  provided,  The automatic  “study” mode is  activated  through the  menu  "Tool  ->
Simbad pointer" and "Tool -> VizieR photometry pointer".  It can also be activated by clicking on
the "study" icon below the view. If this icon is orange then the Simbad pointer is active, if it is green
both the Simbad and VizieR pointers are active. 

Simbad pointer 

To get results from the "Simbad pointer", click in the view and
hold the mouse at the position of interest for 3 seconds. Aladin
will  query  the  Simbad  database  and  return  the  most  precise
identifier,  magnitude,  type  and  coordinates  known  for  the
astronomical object at or near the mouse position. The radius of
this search depends on the zoom factor, and corresponds to one
20th of the size of the view. In case of Simbad is providing several
sources, the one that has been studied the most - i.e. mentioned or
cited in the largest number of research articles - will be selected. 
Then, Aladin displays a label superimposed on the view, attached to the selected source. A mouse
click on the name of the object in this label will  open your web browser on the Simbad page
corresponding to this object.  In the same way, a mouse click on the "Biblio" link will display the
Simbad page of all scientific articles associated with this source.

VizieR pointer 

The "Vizier pointer" is activated in the same way as the "Simbad
pointer"  by  clicking  on  the  intended  location  and  holding  the
mouse in this position for a few seconds. Aladin will then query
the VizieR catalogue service in order to dynamically construct a
SED (Spectral  Energy  Distribution)  based  on  a  collection  of
catalogues  with  flux  measurements  in  different  filters  located
nearby the mouse position. The resulting figure is displayed in the
multi-purpose panel at the bottom right.
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Caution:  There  is  no  guarantee  that  each  of  these  measurements  is  actually  for  the  same
astronomical  object,  nor  that  these  flux  measurements  are  really  comparable.  These  are  only
measurements obtained within a few arcseconds of the mouse position. 

The graph can be displayed in wavelength or frequency by pressing the small "~" button in the
upper  right  corner.  The vertical  bar  represents  the  optical  band.  The graph can  be  enlarged if
necessary by changing the proportion of the lower and right-hand panels in the Aladin window. If
necessary, the small "+" button will open your browser with the same
figure but drawn by a more powerful Web tool provided by the CDS,
which allows for printing and saving.

A click on the icon "table" on top of the graph or on one of the points
in the figure leads to the creation of a new catalogue plane containing
all  the measurements.  The sky location of these measurements will
now  also  be  visible  in  the  view,  and  the  values  displayed  in  the
measurements  window. The line corresponding to  the clicked point
will be automatically selected.

The simultaneous selection of several planes from the
"VizieR  pointer"  measurements  results  in  the
superimposed plotting of the SEDs in the multi-purpose
panel.

Tip: In the case of a joint activation of both "pointers",
the VizieR query will not take into account the position
directly  under  the  mouse  but  the  coordinates  of  the
object provided by Simbad. This method increases the
likelihood that the flux measurements are actually taken
for the same object.

Finally, in the case where the flux data is dated, a "time"
icon appears beside the "table" icon. Its activation will

generate a time graph (see section XX) whose x-axis will be the date and y-axis the corresponding
flux value. This provides a light curve, keeping in mind the warning previously mentioned about the
heterogeneous origin of the data and the various calculation methods.

5.11 Catalogue correlator 

Button: cross  
Menu: Catalogue => Cross match objects ...
Data type: Classic catalogues only
Script: xmatch ...

Aladin integrates a source correlation tool. The aim is to determine the sources common to two
catalogues. The correlator will consider 2 catalogue plans, operate the correlation and generate a
new catalogue plan containing the common objects.
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Note: The correlator described here only applies to pre-loaded catalogues, not to be confused with
the possibility of correlating a local map and a remote table located at the CDS via the "collection
tree" and the "access window".

The window that controls the correlation can be accessed via the "cross" button or the "Catalogue
=> Cross match objects ..." menu.

The 3 modes of correlation

Aladin offers 3 correlation modes accessible via the tabs at the top of the correlation window:
➢ A correlation based solely on the position;
➢ A "per field" correlation based on the presence of identical values in a column of each cata-

logue (typically an identifier);
➢ Position-based correlation with consideration of error ellipses.

 Correlation by position

The panel of the positional correlator allows to indicate
the  2  catalogues  concerned  as  well  as  the  columns
corresponding to  the  position  (ra,dec).  If  there  is  no
ambiguity, the names of the columns have already been
correctly  filled  in  by  Aladin.  It  is  then  necessary  to
indicate the upper or lower separation limit for which
the  sources  will  be  correlated.  It  is  expressed  in  arc
seconds. Finally, a selector offers 3 choices:

1. When  there  are  several  objects  in  the
correlation circle,  only the closest  source will
be correlated;

2. Or  on  the  contrary,  all  combinations  will  be
kept;

3. Alternatively, only sources with no counterparts will be retained.

Correlation by field

Field correlation consists of bringing together sources with a field value that is present identically in
both catalogues. This type of correlation is dedicated to a field that uniquely identifies each source,
for example an identifier, a serial number, etc. In the database, this is called a "join".

Correlation by ellipses

The panel for controlling correlation by ellipses is similar to that for simple correlation by position.
The notable  difference  is  the  possibility  to  specify  not  only  the  position  columns  but  also  the
columns that give the position error. This error must be expressed in the form of 3 fields describing
an ellipse: the major axis, the minor axis and the orientation with respect to the north.

Choice of fields to be kept

When Aladin performs a correlation, he creates a new catalogue plan with
the results. Each pair of correlated sources will correspond to a source in
the result plane, and by default, all measurements from both sources will
be retained. To avoid possible confusion on column names, they will be
automatically suffixed with " _tab1 ", respectively " _tab2 ".
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By  using  the  "Advanced  options"  button  in  each  of  the  correlation
forms, it is possible to explicitly choose the columns to be kept and to
specify the suffixes or possibly the prefixes of the column names.

Columns and UCDs   

When the mouse pointer hovers over the buttons to select the columns,
the corresponding buttons in the two catalogues will be displayed on a
blue background. This correspondence is based on common UCDs for
these two columns (a UCD is an attribute specific to each column which
characterises its physical meaning - e.g. "pos.eq.dec" for a declination
measurement - see the description of UCDs in the 5.8 section).

Note: Some UCDs should only appear once in a table ("meta_main"). Thus, if the correspondence is
displayed on a red background, it  means that there will  be a conflict of UCDs. To remove the
conflict, it is necessary to click on the name of the preponderant column by holding down the Ctrl
key. In the absence of any indication, the column of the first catalogue will be the most important
one.

5.12 Scatter plot / time series

Button: x-y , 
Menu: Catalog => Create a scatter/time plot
Data type: Classic catalogues only

The "scatter plot" tool allows you to compare two quantities taken from the measurements in a
catalogue. Activating this tool after selecting the catalogue plan
in the stack will create an additional view that will display the a
scatter plot. At the same time, Aladin will open the properties
window of this plane so that you can specify the two quantities
to be compared. 

The "scatter plot" can be manipulated in a similar way to a classic view (zoom, move). It is possible
to select the concerned sources and by this means to be able to immediately see, in another view,
their location on the sky.
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Tip:  It is possible to plot several "scatter plots" from different planes simultaneously on the same
graph.  To  do  this,  drag  and  drop  the  logo  of  the  planes  for  which  you  wish  to  visualize  the
scatterplot  on an already created graph.  However,  it  will  be necessary to  indicate  the columns
concerned for each added plane.

In the particular case of a "time series", i.e. when the column chosen for the x-axis is a date, the
view used has specific characteristics. The zoom behaviour differs slightly: only the time scale (x
axis) will be impacted by the zoom factor, and not the value scale (y axis), which will have the
effect of contracting (resp. expanding) the graph horizontally. On the other hand, such a "temporal"
view can superimpose the time component  of  a  temporal  or  spatio-temporal  MOC (see 5.1.4).

Note:  The "scatter plot"  tool remains relatively basic. Do not hesitate to use another tool such as
TOPcat in conjunction with Aladin through the SAMP exchange interface described in section 6.4.
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5.13 Column calculator 
Menu: Catalog => Add a new column...
Measurements pop-up menu: Add a new column...
Script: addcol ...

The catalogues contain a set of measurements that can be viewed in the "measurements panel" by
selecting the relevant sources (see 5.1.8). These measurements are presented as several columns of
values. Aladin provides the possibility of adding columns that are obtained by calculation on the
values  of  other  columns.  For  example,  it  is  possible  to  create  a  "B-V"  column  providing  the
difference between two columns of magnitude "B" and "V". 

Acces to the window

The window for managing the calculation of a new column is
opened either by the contextual menu of the "measures panel"
(right click or CTRL click), or via the main menu "Catalog
=> Add a new column...". In the latter case, you will have to
specify the catalogue concerned beforehand by selecting its
plan in the stack.

General information on the new column

The creation of a new column requires the specification of a
name. Optionally you can specify the unit of the new column
and the UCD to be associated with (see  5.8). You can also
specify  the  number  of  significant  decimal  when  displaying
values.

Calculation expression

To  create  a  new  column,  it  is  necessary  to  indicate  the
calculation expression that Aladin must use to generate the values of this new column. The entry is
made in the central box entitled "Expression". The syntax used follows the usual conventions of an
algebraic expression. References to other columns respect the syntax:

${column_name}

To avoid typing errors, the window displays a list of buttons with the names of the columns in the
relevant catalogue. A mouse click on one of them inserts, at the cursor position in the expression
entry panel, the reference to the concerned column.
It is also possible to insert the operators (+, -, *, /...) and any mathematical functions (abs, cos, sin,
rad2deg, ...) by clicking on the corresponding buttons and selectors.

Generation of the column

Once created using the "Add new column" button, the new values will appear on the far right of the
measurement table, and in a brown/orange colour so that they can be easily distinguished from the
original measurements. This new column can be used like all the other columns: sorted, filtered... It
will be saved with the other columns if necessary.
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5.14  Astrometrical calibration window
Menu : Image => Astrometrical calibration
Types of images : fits, jpeg, png only

Whenever  Aladin  superimpose  sources  over  an  image,  it  uses  astrometric  solution
associated to the image. More precisely, this information makes the link between each and
every pixel in the image and the corresponding position in the sky, and vice-versa. There
are several possibilities usually describing the method used to project a part of the celestial
sphere onto a plane (tangential, sinusoidal, ...). Aladin handles the most commonly used
projection  in  astronomy   (SINUS,  TANGENTIAL,  AITOFF,  ZENITAL_EQUAL_AREA,
STEREOGRAPHIC, CARTESIAN, NCP, ZPN, …)

Information on the astrometric calibration 

Aladin supports 4 methods in order to obtain the astrometric calibration for an image  :
1. When dealing with FITS format images, the calibration information is present in the

keywords from the FITS header  (according to the WCS standard );
2. In  the  case  of  the  JPEG  or PNG  images,  Aladin  is  also  able  to  recognise  the

astrometric calibration given in its comment segment. This calibration has to follow
the syntax of the FITS keywords, adding an ‘\n’ at the end of each line;

3. The calibration associated to a JPEG or PNG image can also be stored in a text file
having the same name as the associated image, but having an ".hhh" extension. In
this case, the syntax can be either FITS (header aligned on 80 bytes), or ASCII with
an ordinary carriage return; 

4. Finally,  Aladin also handle the  astrometric calibration once the image was loaded
from a list  compatible with the VO (Virtual  Observatory) standard: SIA (Simple
Image Access, see 8.1 - Types of supported data).

Tip: In the first two cases, the FITS header can be visualised via the  Edit => FITS header
menu.

One  image  can  support  several
astrometric  calibrations,  in  particular
if it was generated manually. In order
to switch from an astrometric solution to another, just display the plane properties and change the
selection. 

However, if the image do not have an astrometric calibration, Aladin may still generate views but
will not be able to superimpose sources or graphical overlays having celestial  coordinates. "No
astrometrical reduction" will be displayed in the location field, when moving the mouse cursor over
this kind of image. But, it is possible to add graphical overlays manually (freehand drawings, marks
), contours… These graphical will have no other coordinates than the XY coordinates specific to the
image. 
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Creation/modification of an astrometric calibration

Aladin can be used to  create
manually  an  astrometric
solution  for  an  image  which
do not  have one,  but  also  to
refine an already existing one.
The first  step is to select the
image plane in the stack (just
click on the image name ) and
then, secondly, use the menu
"Image  => Astrometric
calibration…".

The calibration window will ask
you to give a name for this new
calibration you just created.

Then,  the  user  dispose  of  3
methods to create/modify a calibration  :

1. By parameters;
2. By matching stars;
3. By WCS header.

Calibration using the parameters

The first tab displays basic parameters for the astrometric solution,
namely  the  celestial  position  and  the  image  corresponding  pixel
coordinates, the pixel angular size, the projection method, a rotation
angle and the increasing direction of the right ascension. 

Calibration using the WCS header

The 3th tab displays FITS keywords describing the parameters for the
calibration  in  the  WCS  standard.  If  the  standard  is  known,  you  can
directly modify the parameters. For example, one can use the astrometric
solution from another image by copy/paste its WCS parameters.

Tip : It is also possible to modify the value of the WCS keyword via the
script command: set  PlanID FITS:keyword=value (see  7.1 -  Aladin by
script)

Calibration by star matching

The  table  displayed  in  the  2nd tab  is  used  to  write  a  list  of  XY image  coordinates  and  their
corresponding celestial coordinates. It is a powerful and flexible method allowing to obtain rapidly
good  calibrations. We will briefly describe this method here. For more details, please check the
CDS10 website  and  refer  to  the  online  dedicated  tutorial.  Assuming  we  loaded  an  JPEG  non
calibrated image in the left view, and in the right view, a DSS image from the same field of view

10 http://cds.unistra.fr/tutorials/pdf/aladin-tutorial-astrometric-calibration.pdf
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overlayed with an astrometrical catalogue, such as UCAC5. In order to calibrate the JPEG image,
one can use the following method: click successively on a star in the non-calibrated image, and then
click on the corresponding UCAC5 source from the DSS image. For every click, Aladin fills in the
table form the calibration board. Four corresponding measures are usually enough to get a good
calibration.

Note: When one needs to determine the coordinates for a start using the clicking method, Aladin
uses a barycentre centroid algorithm. If it is not possible to determine the centre (the star is too
wide), a message will be display to inform you that the clicked location will be taken as it is. 

Tips :
➢ It can be useful to perform a “rotation” (Ctrl+click/navigate in the view, - only possible for a

progressive HiPS survey) of the reference image in order to get closer of the orientation of
the image needing to be calibrated. 

➢ It is better to display only the brightest low proper motion sources. Using a filter for
the catalogue ease the identification of the corresponding sources, for example :  
$[pos.pm;pos.eq.dec]<3  mas/yr  &&  $[pos.pm;pos.eq.ra]<3  mas/yr
   && $[phot.mag*]<17  { draw circle(-$[phot.mag*]) }

➢ If no catalogue is loaded, the celestial coordinates will then be the ones resulting from the
DSS image calibration. But, the precision of the calibration will be lower. 

➢ Using the semi-transparence (Menu “image=>Transparency level”) to visualise the image
one just calibrated with the DSS image as background, allows you to simply check in a
glance the quality of the calibration.

Do and undo

During the calibration creation or adjustment process, it is possible to go back
to a former solution by using the “Redo” and “Undo” buttons at the bottom of the window.

5.15 RGB colour image generator 

Icon: rgb
Menu: Image =>  RGB image builder...
Type of images: fits, jpeg or png in grayscales
Script: RGB, RGBdiff

Aladin  can  create  a  true  colour
image  from  2  or  3  "B&W"
images.  To  do  this,  Aladin will
assign the first image to the "red"
component  and  the  other  two
images to the "green" and "blue"
components.  The  true  colour
image  will  be  stored  in  a  stack
plane.
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Resampling 

In order to ensure that the pixels of the images correspond to the same positions in the sky, Aladin
resamples two of the images according to the astrometric solution of the third. This is called the
"reference image". By default, the image with the smallest angular size of the pixel will be used as a
reference. Resampling is based on the "nearest pixel" algorithm (see 5.16).

Access to the window

The  window  for  generating  a  colour  image
can  be  accessed  either  through  the  menu  "
Image => RGB image builder... "  or through
the "rgb" button.

The  default  selection  of  images  for  each
component depends on the state of the stack.
If there are two or three plans selected, Aladin
will use them to fill in the form. Otherwise,
Aladin will consider the 3 images at the top of
the stack, or the first 2. If he knows the wavelengths of the images, Aladin will sort them according
to this parameter.

Tip: When the mouse cursor is over the logo of the created RGB plan, the
logos  of  the  3  original  images  appear  in  the  colour  of  their  own
component. 

Special case of 2 images

Only 2 images can be selected. In this case, the third colour component will be calculated based on
the other 2 by taking the average of the values of the other 2 images. This method builds very
beautiful coloured images especially if the missing component is the green one (default mode).

Differences between 2 images   

With 2 images, it is also possible to perform colour subtraction.
The positive differences will be the values of the first colour
component, the negative differences will be the values of the
second  colour  component.  Also,  the  differences  will  be
normalized between 0 and 255 for maximize the contrast. This
method is very interesting to quickly visualise even the slightest
variations between 2 images. 

5.16 Image associations: cubes &
mosaics 

Icon: assoc 
Menu: Image => Mosaic image builder…

Image => Blink/Movie generator...
Type of images: fits, jpeg or png in grayscales
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Script: blink ..., mosaic ...

Aladin can associate 2 or more images by combining them either in the form of a cube which he
will display as an animated sequence, or by creating a new mosaic image of the original images. 

Access to the association window

The window that opens via the menu "  Image => Mosaic
image builder... " or " Image => Blink/Movie generator ", or
via the " assoc " button allows you to control the association.
You  will  indicate  the  original  image  plans,  the  initial
sequence  delay  in  the  case  of  producing  a  cube  and  the
reference image if a resampling is required to superimpose
the pixels.

Mosaic

In  case  of  production  of  a  "mosaic"  image,  the  resulting
image will have the size required to contain all the original

images  in  the
projection  grid
of  the  reference  image.  The  obtained  image  will  be
visualised  and  manipulated  like  any  other  image  in
Aladin. The average will be used for overlapping areas.

For more information: This mosaic image generation
function  is  relatively  simplistic  (number  of  images

limited to RAM, no background adjustment, no exclusion mask, ...). However you can also generate
a mosaic of images in the form of a HiPS. To do this, please refer to section 6.2.

Cube or "animated sequence”

A cube is visualised by Aladin as an animated
sequence, i.e. frame after frame. The logo in the
stack is identified by a double line at  its base
symbolising  the  thickness  of  the  cube.  The
handling of a cube is described in the section on
"the view" in 5.1.2.

The scrolling control of the cube is done either
via the red icons superimposed on the view, or
via the "cube" slider located under the stack. If
this slider is not visible, activate it via the user preferences (Edit menu).

Tip: It is possible to add a new image to an existing cube. To do this, you must click/drag the logo
of the new image in the view where the cube is scrolling. After a short pause required to resample
the new image, the scrolling of the cube resumes with one more image.

For more information: It is possible to extract a localised spectrum from a cube (see 5.1.5- Depth
cutting associated with the "Spect" tool ).
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5.17 Image resampling 
Menu Image => Resampling...
Type of images: fits, jpeg or png in grayscales
Script: resamp ...

Principle

Even if it concerns the same field of the sky,
each image usually  is  provided with its  own
astrometric  solution.  This  means  that  a
particular  pixel  does  not  necessarily  point  to
the same place in the sky. In order to compare
two pixel-by-pixel images, it is often necessary
to  resample  one  of  them  against  the  other,
known as  the  "reference  image".  In  concrete
terms,  Aladin  will  go  through  all  the  pixel
positions of the reference image, deduce their
coordinates in the sky, and then using this time
the astrometric solution of the second image,
for each celestial position previously calculated, he will deduce the value of the pixel, either the
closest to the position found, or a bilinear approximation of the 4 closest pixels. At the end of the
process you will have two images with the same pixel "grid" for a single astrometric solution.

Access to the window

The window that controls resampling is opened by the menu "Image => Resampling...". The image
to  be  resampled  must  first  be  selected  from the  stack.  In  the  window,  you  must  indicate  the
reference image, whether or not to keep the full pixel value or just the 8-bit coded "grey levels",
choose the method for estimating the pixel value and finally indicate whether the original image
should be replaced by the resampled image or kept in the stack.

Warning: It should be noted that the resampling methods proposed by Aladin (closer or bilinear) do
not  necessarily  ensure  the  conservation  of  the  flux,  i.e.  the  sum  of  the  pixel  values  before
resampling is not necessarily the same as after.

Note: A resampled image shows the logo  in the view. 

Tip:  The use of  semi-transparent  images  (see  5.1.2)  provides  a  much faster  and more  flexible
alternative to resampling. However, it is less precise since it does not act pixel by pixel but only on
the basis of the 4 corners and globally approximates the position of the other pixels.

5.18 Arithmetic operations on images 
Menu: Image => Arithmetic operation...

Image => Convolution...
Image => Pixel normalisation

Type of images: fits
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Script: +, -, *, /, conv, norm, kernel

Addition, subtraction, multiplication and division

Aladin offers a simple interface to perform basic
calculations  on  a  pair  of  images:  addition,
subtraction,  multiplication,  division.  The
dedicated  control  window  is  available via  the
menu  "  Image  =>  Arithmetic  operation...  "
(accessible only if at least two images are present
in the stack). Aladin will proceed pixel by pixel,
resampling the second image if necessary, so that
it matches the pixel grid of the first. It is possible
to request a prior normalisation of the pixel range
of two images so that their values are distributed
around 1 by prior division by the average.  The
result  of  the  operation  will  be  seen  as  a  new
image plane in the stack.

Convolution 

Additionally, the menu " Image => Convolution ... " allows you to "convolve" the current image
with a specific matrix, i.e. to calculate a new image according to the product of each original pixel
(and those nearby) with a particular matrix. The sub-menu proposes the matrices commonly used in
astronomy (Gauss, Mex, Tophat, ...) of  various sizes. You can also define your own convolution
matrix using the script command: "conv" (see  7.1). The resulting image will replace the original
image in the stack. If you wish to keep the original image, it is necessary to duplicate it beforehand
(menu: " Image => Duplicate the image plane").

5.19 Backups, exports and printing 
Menu: File => Save..., File => Export..., File => Export...

File => Save..., File => Print..., File => Print...
Shortcut: Ctrl +S, Ctrl +P
Script: save ..., export ...

Save, export and print functions can be ac-
cessed through the main "File" menu. 

Aladin has several possibilities to save your
work:

➢ Printing the view(s);
➢ Saving the current view. Supported formats are BMP , JPEG , PNG and EPS . This last

format  is  especially  indicated  for
scientific publication;

➢ Exporting one or more  plans from
the  stack.  The  images  will  be
exported in FITS , JPEG or PNG,
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the catalogues in TSV (Tab-Separated-Value) or VOTABLE (see 8.1), FITS and JSON for
the MOCs;

➢ backup of the stack and views for later re-use.

Generation of a "clickable" map 

In the case of saving the view Aladin proposes the " PNG+LINK " format. This format is dedicated
to the creation of "clickable web maps". The view is saved in regular PNG format. A second file is
simultaneously  generated  with  the  ".lnk"  extension.  It  contains,  in  a  basic  ASCII  format,  the
clickable objects present in the view, their position in the PNG image as well as a URL to access the
complete associated record. These two files placed on a Web server will allow the easiness creation
of a clickable map. For more details on the method, the format and examples of implementation,
please consult the following address:
 http://aladin.cds.unistra.fr/java/FAQ.htx#Map.

5.20 Bookmarks 
Icon:  
Menu: Tool => Bookmarks...
Script: function ..., call ...

Aladin provides a "bookmark" mechanism that allows you to perform a series of predetermined
actions with a simple mouse click on one of the buttons visible in
the control panel (see 5.1.7).

Some bookmarks have been predefined by the CDS team. They appear with a green symbol. You
can create your own bookmarks with a blue symbol.

The window that opens by clicking on the "+" icon on the far right of the bookmarks bar, or via the
"Tool -> Bookmarks..." menu, allows you to view existing bookmarks, modify them, or even create
new ones. In the upper part of this window you will find the table of defined bookmarks. If you
select a row, the actions associated with this bookmark appear in the panel below the table. 

A bookmark is stored internally as a "script function",
i.e. a list of script commands (see  7.1). A name, and
optional  parameters,  will  be  attached  to  it.  Two
predefined  parameters  are  particularly  useful:
$TARGET which will be replaced by the position of
the reticle when the bookmark is called, and $RADIUS
for  the  radius  covering  the  current  field  of  view.
Adding a comment above the function definition, will
provide a short  description.  This information will  be
displayed  via the  "tooltip"  of  the  corresponding
bookmark.

Technical  note:  Resetting  Aladin's  "cache"  (see
glossary),  or installing a  new version may cause the
update of the bookmarks displayed in the bar below the
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menu.  Your  own bookmarks  are  not  deleted,  however.  Simply  revalidate  them in  the  window
described above.

5.21 User preferences 
Menu: Edit => User preferences...

Aladin groups together most of the user's configuration parameters in the preferences window. You
can thus define the following items:

➢ The language of the graphic interface (English, French, Italian, ...);
➢ Activation of the "Wizard" mode offering context-sensitive help;
➢ The rendering of the interface (light or dark theme, font size and icons);
➢ The style of the access window to files and directories (depending on the operating system,

or specific to the Aladin application);
➢ The choice of control strips under the stack;
➢ The default directory where Aladin searches or saves local files;
➢ The spatial reference frame and the default projection;
➢ The default pixel display mode (inverted video, colour table...);
➢ The activation or not of the dedicated filters (see 5.8);
➢ The default image server;
➢ The default site of the server directory (see  5.2), i.e. the machine that provides the server

directory with a list of available servers every time it is started ...;
➢ The graphic choices of the coordinate grid and view information (colour, font size);
➢ The activation of the CDS metrology tools (log);
➢ The size of the local buffer (cache);
➢ Automatic filtering of FITS data extensions considered irrelevant;
➢ Access and manipulation of planetary data.

Some clarifications:

Interface – UI scale: Screens with a particularly high number of pixels relative to the physical size
(HDPI  screens)  may  require  fonts,  icons  and  other  interface  elements  to  be  scaled  up.  This
enlargement  factor  can  be  automatic  ("auto"),  leaving the  Operating  System to  make the  most
appropriate choice. Unfortunately this is not always the case. This is why Aladin offers manual
alternatives in terms of percentage of growth (110%, 120%...) and allows the user to determine this
growth factor himself. It is therefore necessary to carry out some tests to choose the best option.

File dialog style: Some operating systems provide forms for accessing files and directories that can
be reused by software such as Aladin. This keeps the same working habits from one program to
another.  However,  some  Operating  Systems  do  not  offer  all  the  expected  functionalities,  for
example the selection of a directory. This is why the user is left free to opt for a generic form,
provided by the Java library.

Permanent disk cache: Aladin's function requires to download a large amount of data, especially
when browsing progressive surveys. Statistics show that a user often works on the same data, the
same place in the sky, which means that he will often reload the same data. This is why Aladin
relies  heavily on the notion of "buffering",  i.e.  copies  on the local disk of the most frequently
accessed data. This allows for a much faster visualisation, but it saves resources that the planet
really needs. Do not hesitate to provide a large value.
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CDS logs:  You are using Aladin developed by the Strasbourg Astronomical Data Centre for free.
You will greatly help the development team by activating this usage statistics mechanism (short
usage reports (los) automatically transmitted to the CDS). They are anonymous and do not contain
any local or personal information (file names, directories, ...). These statistics are valuable to justify
the  activity  of  the  CDS  to  its  French  governmental  authorities,  and  to  decide  on  future
developments. You can of course reject this option according to your preferences.

Planetary data: Starting with Aladin version 12, it is possible to activate access to planetary data
(surfaces, catalogues, coverage). However, these data are dependent on the evolution of the IVOA
standards associated with planets. The current state of these protocols does not always provide an
optimal way to differentiate planetary data from celestial data. Access to planetary data is therefore
provided  "as  is",  with  no  guarantee  of  a  consistent  display.  When  this  option  is  enabled,  the
collection tree will display a new "Solar System" branch to access these resources. If Aladin cannot
be sure that the data to be overlaid are consistent (same planet, only celestial, ...) it will display an
alert message reminding the potential problem.

The preferences window also allows you to:
➢ Create your own translation language (see below);
➢ Reload all  data server definitions during the session,  which will  also have the effect  of

resetting Aladin's internal metadata cache.

Note: Some parameters are not configurable through the preferences window, but simply kept from
one session to another, for example, the size and location of the Aladin window, the type of reticle
(large or classic), whether or not to activate tooltips on the sources, etc.

Tip:  The configuration parameters are  kept  in  a  simple ASCII  file  ".aladin.conf"  which can be
edited in the ".aladin" directory present in your home directory ($HOME in unix, \Users\YourName
in Windows). To reset the settings to the original configuration, simply delete this file.

Management of the interface language

Aladin supports  several  languages  for  its  graphical  interface.  It  is  possible  to  create  your  own
translation if the language you want is not yet supported or not fully translated. To do this, use the
"New translation" button and specify - in English - your language and the corresponding "2 letter"
code (e.g. "French" - "fr"). Aladin opens an editing window that displays all the expressions that
need to be translated (in English), those that have already been translated if necessary and those that
are no longer necessary (used by an earlier version). You can install your translation which will
appear at the next session as a possible language alternative in the list of supported translations.

Further information:
➢ Expressions that are not translated will appear in English.
➢ Aladin supports non-ASCII languages (e.g. Chinese...) and possibly written from right to 

left (e.g. Persian...).
➢ It is possible to complete or fix an existing translation. To do so, you must first install the 

language in question and then press the "New translation" button, leaving the "Language" 
and "2 letter code" fields blank. Your translation additions will only concern your own in-
stallation of Aladin.
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Note: If you wish, you can contact the CDS11 and Aladin's development team in order to share your 
work with the user community. Your translation file is saved in the same directory as Aladin's 
configuration file (see above) with the name "Aladin-langue-version-perso.string...".

5.22 The script console
Menu: Tool => Script Console...
Shortcut: F5

All  the  actions  that  can  be  performed via  the  graphical  interface  can  also  be  done by "online
commands". The aim is to be able to use Aladin in "script" mode to execute repetitive actions, to
instruct treatments to be performed or to control Aladin remotely. 

These commands can be submitted through different channels, the main ones being:
➢ The "Command" field under the menu;
➢ The "Script Console";
➢ A command file;
➢ The standard input.

The script console is opened via the menu "Tool
=> Script Console...". This window displays, as a
table, all the commands equivalent to the actions
that  have  already  been  carried  out  via  the
graphical interface during the session, as well as
for previous sessions. It is a  useful help to learn
the  syntax.  It  is  possible  to  type  one  or  more
commands  directly  into  the  input  field in  the
middle of the window. 

Tip:  selecting one or more commands from the
table  with  the  mouse  will  copy  them  into  the
input field for editing and execution.

Alternative to the console

If you want to quickly  pass a command without
opening the command console,  you can enter it
directly in the "Command" field under the main
menu (see 5.1.5).

The  small  triangle  to  the  left  of  this  field  opens  the  history  of  all  previously  executed  script
commands (via a real script command, or via an action in the GUI). This list can also be consulted
by using the Up and Down arrows in the input field.

Tip: You do not need to click on the "Command" field before entering a command on the keyboard.
By  using  the  "up"  and  "down"  arrows,  you  can  quickly  display  the  previous  (or  subsequent)
commands again.

11 cds-question to unistra.fr
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Please refer to the "Aladin by script" section (see 7.1, below) for more information on controlling
Aladin by script.
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6 Ancillary tools 
Aladin has additional tools that enlarge its scope of application, including:

➢ A "macro" manager for repetitive work;
➢ A tool for generating progressive surveys (HiPS);
➢ A tool for generating coverage map (MOC);
➢ A mechanism for interaction with other astronomical tools compatible with the "Virtual 

Observatory";
➢ A source extraction tool: S-extractor;
➢ A "thumbnail view" generator

We will briefly present each of these tools.

6.1 The macro manager 
Menu: Tool => Macro controller...
Script: macro ...

To  facilitate  repetitive  processing,  Aladin  offers  a  "macro"
mechanism based on script commands (see 7.1). The idea is to write
a script that uses text commands that can incorporate variable names
so that the script can be used repeatedly, for example on a list of
object names.

The  macro  window  is  available via  the  menu  "Tools  => Macro
controller...". It is divided into 3 parts:

1. The top panel allows you to enter a script. This can include
"variables" named $1, $2, etc..;

2. The middle panel provides a list of values that the variables
can take;

3. The bottom panel is used to control the execution.

Alternatively, the value list loading (central table) can be generated
from the sources of one of the catalogue plans of the stack (File menu of the "Macros" window).

The script as well as the parameter values can be saved for later reloading (same menu).

Tip:  When entering the script, Aladin automatically recognises the syntax and highlights it with
colours. Commands are "clickable" to quickly display related help.

6.2 HiPS progressive survey generator 

Menu: Tool => Generate a HiPS based on...
Command line: java -jar Aladin.jar -hipsgen ....
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Aladin  integrates  the  "Hipsgen"  library  for  generating  HiPS  progressive  surveys.  This  library,
developed and maintained by the CDS, enables a HiPS to be built quickly and efficiently from a
collection of individual images.

A HiPS,  or  Hierarchical  Progressive  Survey,  is  a  mosaic  of  astronomical  images  stored  as
hierarchical tiles using the HEALPix sky grid. This is a method invented by the CDS and adopted
by  the  IVOA (International  Virtual  Alliance)  in  the  form  of  an  international  standard  whose
document is available at the following address: http://www.ivoa.net/documents/HiPS/. The creation
of a HiPS consists of generating the mosaic, cutting, and then generating the tree structure of the
tiles that make up the final HiPS. Depending on the number of original images and their sizes, this
process can take from a few seconds to several days. 

Technical details: Hipsgen can process 1 terapixel sources in about ten hours on a medium-power
machine. It can handle from 1 to several million source image files. It can manage the a posteriori
addition of additional images in an existing HiPS. It is the tool used by the CDS and most other data
centres  that  provide  progressive  HiPS  surveys:  ESAC,  JAXA,
IRAP, CADC, HEASARC, ...

Note:  To  display  a  HiPS  directly  in  a  web  page,  use  "Aladin
Lite12". This is a code developed by the CDS, written in JavaScript
dedicated to displaying HiPS in a web browser  (opposite,  the  use of
Aladin  Lite  by  the  VIRGO  team  to  visualise  probable  areas  of  gravitational  wave
emissions).

Aladin handle Hipsgen  either through the graphical interface via
the menu "Tool -> Generate a HiPS based on...", or through the
Aladin command line with the "-hipsgen" option. A document dedicated to the generation of HiPS
by online command is available on the CDS website13.

The  use  of  Hipsgen  through  Aladin's  graphical  interface  is  carried  out  in  several  consecutive
operations that can be configured using a form with successive tabs that we will present briefly.

Tab 1: Data description - inputs and outputs

The first tab describes the location of the source image collection. These images can be in FITS,
JPEG or PNG. In all cases, these images must have an astrometric calibration. This calibration can
be classically internal to the image file in the form of WCS (World Coordinate System) keywords
integrated in the FITS header, or in a JPEG or PNG "comment segment", or external, as an ASCII
file with the same name and ".hhh" extension.

12http://aladin.cds.unistra.fr/AladinLite/doc/  
13http://aladin.cds.unistra.fr/hips/HipsIn10Steps.gml  
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Tip: Verify the presence of a compatible astrometric calibration just by displaying a coordinate grid
on an image loaded in Aladin.

Note  :    The  set  of  source  images  can  be  reduced  to  a  single  "HEALPix  map",  i.e.  a  FITS file
describing the sky in a global way using a HEALPix cutout.

The collection of source images is identified by the directory of the disk on which they are stored
(directly or in a tree structure). This can be directly the name of the file in the case of a single
image. This form can also be used to indicate the directory where the HiPS to be produced will be
stored.

This first form also proposes a list of selectors and input fields specifying the operating mode of the
HiPS generator:

➢ BLANK: This input field allows you to specify a specific pixel value to identify those that
should not be taken into account. This field is normally filled in in the FITS header of the
image, but often absent;

➢ HDU: A FITS file can be structured in several extensions called HDU. This field is used to
indicate which extension(s) should be taken into account;

➢ Sky  background: Method of adjusting the level of "sky background" from one image to
another  and  avoiding  "patchy"  effects.  This  input  field  can  take  either  the  value  of  a
keyword,  present  in  the  FITS  header  of  the  images  and  explicitly  providing  the  "sky
background" value for each image (e.g. BKGROUND), or the "auto" value. In this case,
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Aladin/Hipsgen will perform a statistical analysis of each image and will try to determine
each "background" value automatically;

➢ Fade in/out: Activating this selector will cause a "link" effect for each overlay of source
images. By default, a simple average is calculated for each pixel of these overlapping areas.
In fade mode, this average will be weighted by the distance to the nearest edge (only on the
6th of the width (respectively height);

➢ Image edges: In case the source images have unexposed edges (no measurement values), or
erroneous edges (outliers at the edge of the original sensor), this field allows you to indicate
the number of pixels of the image edges to be ignored;

➢ Restriction of the region to be processed: the last input field allows the HiPS calculation
to be restricted to a specific region determined by a sequence of HEALPix indices.

Once these various parameters have been entered, let's move on to the actual creation of the HiPS.

Tab 2: Creation - generation of FITS tiles

The second tab allows you to specify the encoding method to be used to store the pixel values, as
well as the final resolution of the HiPS to be generated. Aladin/Hipsgen uses the first image present
in the source directory to determine the default values.

Now we just have to start creating the HiPS. This is done in two steps corresponding to the two
progress bars. Firstly, the source images are indexed in the HEALPix system, then processed, pixel
by pixel, to produce the HiPS tiles for each hierarchical level.

Tip: The "see coverage" button is activated at the end of the first phase and allows you to control
the area covered by all the source images (as a MOC).
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At the end of step 2, the HiPS is ready, but only available as FITS tiles. These tiles contain all the
dynamics  of the original  pixel values,  but are large in terms of disk space and, when used, in
transfer time. 

Tab 3: Post processing - JPEG/PNG tile generation

The third tab allows you to create a second or even third set of HiPS tiles, but this time, the tiles
will be compressed in JPEG or PNG. These alternative tiles will be added to the tree structure
produced in phase 2 of HiPS generation. The advantage of generating both HiPS tiles in FITS and
JPEG/PNG format will  give HiPS display tools -  such as Aladin Desktop or Aladin Lite -  the
opportunity to choose their access mode, either fast in compressed tiles, or slower but with all the
dynamics of the pixel values.

The parameters on this  tab allow you to specify the range of pixel values that will  be used to
generate the compressed tiles. Two methods are proposed. The first one consists in providing the
two bounds of the range. The second method will take the current setting used by the display of the
HiPS generated in step number 2. This method is more flexible and powerful since it is possible to
take into account the transfer function as you have defined it (see 5.5).

The last  selector of this  form describes the method of calculating hierarchical tiles.  Each HiPS
hierarchical level divides by 4 the number of tiles by aggregating 4 pixels into 1, either by a mean
or a median method.

Tab 4: Publication

The penultimate tab describes  the different  possibilities  for  using  or  even publishing the HiPS
product. 
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Since a HiPS is in fact only a tree structure of files, a simple distribution of it through an http server
will be enough to make it accessible to everyone. Thus, loading the URL of this HiPS in Aladin will
make it accessible like any other HiPS. If it is not a restricted HiPS, the IVOA standard mentioned
above indicates the procedure to follow in order to make your HiPS visible to the astronomical
community, and thus make your HiPS accessible, notably through Aladin's "collection tree".

The last tab is for generating a colour HiPS from two or three previously generated greyscale HiPS.

Tab 5 : Generate RGB

The last tab is used to generate a colour HiPS from two or three previously generated greyscale
HiPS. Each tile of the colour HiPS is generated from the corresponding tiles of the original HiPS. It
is necessary to decide which original HiPS is used for the red,  green and blue components.  In
addition, the range of pixel values that is taken into account for each colour component must be set,
especially  if  the  original  HiPS have inhomogeneous  contrasts.  The choice  of  these  parameters
depends on the desired result: visual quality, highlighting of weak objects, etc.

Aladin has two methods:

1. Classic: For each original HiPS, the pixel range is determined using the same method as the
visual rendering used by Aladin for its interface (see 5.5- Pixel dynamics). It is necessary to
define  the  adopted  interval  ("cut  min",  "cutmax"),  and  possibly  an  alternative  transfer
function to "Linear", as well as a median threshold (cut middle). To facilitate the entry of
these values, they will be automatically transferred from the visual rendering setting if the
HiPS concerned has been loaded into the stack.

2. Lupton:  also Aladin  allows  to  define  the  3 parameters  required  to  apply  the  algorithm
proposed by Lupton (min, strech and Q). For more information on this method, please see
the article "Preparing Ref-Green-Blue Images from CCD Data".14

Note: To generate the RGB HiPS, it is essential that these HiPS are available on the local machine
and not only accessible via an http server. Furthermore, if these original HiPS are loaded into the
Aladin stack, it is possible to dynamically visualise the final result that will be obtained according

14https://ui.adsabs.harvard.edu/abs/2004PASP..116..133L  
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to the selected parameters. The use of multi-windowing will greatly help in the dynamic adjustment
of parameters.

The form also offers the possibility to adjust 3 output parameters:
1. The HiPS hierarchy calculation method: This is the method for generating the parent tile

from its 4 "daughter" tiles, i.e. what pixel value to keep for the 4 corresponding pixels in the
deeper hierarchy level. This can be an average of the 4 pixels involved, or a "false median",
i.e. one of the values of 2 median pixels. The second method is interesting for highlighting
large structures and filaments. These calculation methods are applied colour component by
colour component.

2. The noise reduction filter: The application of a Gaussian filter smoothes the background
noise.

3. Tile format: The PNG format can manage potential transparency, which is interesting in the
case of partial sky surveys. JPEG offers a better compression rate and faster generation, but
does  not  allow  transparency,  and  may  introduce  undesirable  visual  effects  due  to  its
compression algorithm.
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Note:  The "Script command" button displays the parameters of the script command equivalent to
the choices indicated in the form. This allows you to visually prepare the desired rendering, but to
launch the generation of the colour HiPS via a command line "Aladin -hipsgen...".

6.3 MOC coverage generator 

Menu: Couverage => Generate a spatial MOC based on… 
                  =>An image collection
Order line: java -jar Aladin.jar -mocgen ....

Aladin integrates the Mocgen library to generate a spatial MOC coverage from a collection of im-
ages. As with the generation of a HiPS, Aladin/Mocgen will process a collection of source images 
stored in a directory in the form of a list or tree structure of image files. The supported formats are 
identical to those described in the previous section (see 6.2).

Mocgen's control parameters do not present any difficulties. However, it should be noted that there 
is a big difference in processing time if one chooses to build the MOC solely on the basis of the 
WCS header of each image without trying to examine each pixel of each image one by one.

For more information: there is no need to generate a MOC following the creation of a HiPS. In fact,
when the HiPS is generated, the corresponding MOC will already have been calculated and stored 
in the root directory of the HiPS under the file name "Moc.fits".

One can also create a temporal MOC or a Space-Time MOC: Couverage => Generate a temporal 
MOC… , Couverage => Generate a Spatial-Time MOC based on…

6.4 Interaction with VO tools: SAMP 

Menu: Tool => VO tools
Data types: Catalogues, Images, Spectra (no HiPS)
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Aladin  manipulates  images  and  catalogues  to  generate  views.  However,  it  can  rely  on  other
independent applications to carry out other processes such as generating 2D graphs,  displaying
spectra,  etc.  For  this  purpose,  Aladin  implements  the  protocol  standardised  by  the  Virtual
Observatory called SAMP for Simple Application Messaging Protocol..

Principle

SAMP allows applications to dialogue with each other so that they can not only transmit data to
each other, but also interact with each other. Thus the selection of an astronomical source will, for
example, be visualised simultaneously in all applications.

Installation

Aladin  facilitates  the  use  of  SAMP by presenting  in  a  window a  list  of  applications  that  can
"dialogue" with Aladin. This window offers the possibility to easily install one or other of these
applications, so that they appear
in the "Tool => VO tools => ..."
menu and can be easily started.
This list is dynamically updated,
so that it shows the new features,
the new versions available...

SAMP connection

To make two SAMP-compatible
applications  interact,  they  only
need  to  run  simultaneously.
Aladin  offers  the  possibility  to
start  another  SAMP application
directly  from  the  menu  "  Tool
=> VO tools".

When the two applications are running, they will "see" each other according to the mode that is
specific to each one, for example in an "Interop" menu (TOPCAT, VOPlot, VOSpec, Aladin...),
"File => SAMP" (DS9), or thanks to a dedicated icon (CASSIS, Aladin).

Aladin visualises the SAMP "connections" using the radar antenna icon at the bottom right of his
main window. If this icon is drawn with a series of "waves", it means that one or more other SAMP
compatible applications are running and can interact with Aladin.

The  "Interop"  menu  groups  together  all  the
functionalities  associated  with  SAMP  and  gives
access to the options. It is also possible to use the
contextual  menu  (right-click  or  CTRL  click)  by
placing the mouse directly on the "antenna".

Data transfer

Once Aladin is "connected" to another application, it
can receive data (images, tables, etc.) that will appear as new plan in the stack. He can also send
data. The method consists in selecting the plan(s) concerned in the stack, then opening the "Interop"
menu to designate the "target" SAMP application in the appropriate sub-menu.
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Interactions

Usually,  when  the  data  is  tables  or
catalogues,  the  sources  selected  in  one
application are automatically selected in the
other application. This is a very convenient
method  for  locating  where  sources  with
peculiarities  in  their  measurements  are
located  in  the  Aladin  field  and  in  a
colour/colour graph in TOPcat.

Note: The "SAMP" actions depend on the
applications,  it  is  possible  that  an  object  selection  is  simply  ignored  by  a  SAMP compatible
application but which did not want to implement this feature.

6.5 Spectra manipulation via CASSIS 

Menu: Tool => VO tools => CASSIS...
Type of data: Classic FITS cubes

The "spect" tool may be used to extract a spectrum from a data cube previously loaded into Aladin
(see section 5.1.5). This is a basic tool for visualisation only. Therefore, Aladin can use an external
tool  specialised  in  spectral  analysis:  CASSIS.  This  is  a  software  package  developed  by IRAP
(Toulouse/France),  and a Aladin-compatible plugin can be easily downloaded/installed for use in
interaction with Aladin.

Installation/execution of the CASSIS plugin

The CASSIS plugin can be installed and run in a few clicks via the menu "Tool → OV Tools →
CASSIS spectrum alalyzer".

Spectrum extraction and analysis via CASSIS

Aladin has three tools for extracting a spectrum from a data cube. These are the “spect” tool, which
extracts at a single point, the “phot” tool and the “draw” tool, which averages the values over a
circle or polygon. As soon as CASSIS is active, each extracted spectrum is automatically transferred
to CASSIS for display and analysis. In case the data cube does not have information about the
scales that are used, CASSIS offers a small form to fill in the required information.

A post modification of the extraction tools (position, surface) is possible and automatically updates
the corresponding spectra in CASSIS. 

Usage of CASSIS

The CASSIS plugin is  almost  identical  to its  regular version.  It  has a few additional  functions
specific to its use in association with Aladin. In particular, it is possible to use the central mouse
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button to designate an area on the spectrum which results in the creation of an image in Aladin. This
image is the average of the original cube values for the designated area.

The  CASSIS  documentation  is  available  online  (http://cassis.irap.omp.eu/help/)  and  directly
accessible via the CASSIS menu "Help → Users-s manual".

6.6 Source extraction via SExtractor 

Menu: File => Server selector => Tools => S-extractor...
Type of images: Classic FITS images

Aladin does not have native automatic
source  extraction tools.  However,  he
can  use  the  "SExtractor"  which  is  a
software  commonly  used  by
astronomers  to  extract  sources  from
an  image  and  calculate  magnitude
values (Bertin & Arnouts - 1996).

The menu "  File =>  Server selector
=> Tools => S-extractor "  opens the
"  Server  selector  "  on  the  tab
concerning  the  SExtrator  tool.  This
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form presents the main parameters for source extraction and a selector to designate the concerned
image - plane.

Validation of this form involves remote querying of a server located at the CDS in Strasbourg and 
dedicated to this type of work. This machine will run SExtractor on your image, and return the ex-
tracted source table. These will appear in the stack and therefore projected on the image.

6.7 Generation of thumbnails 

Menu: View => Create one view per image  
Image types: HiPS and classic images
Script: thumbnail ...

Aladin offers the possibility to easily generate thumbnails for a list of objects, i.e. a series of images
centred on the objects in the list. To do this, Aladin will create as many "views" (see 5.1.3) as there
are objects. The relevant objects are either those selected in the current view, or all the sources in a
catalogue plan or a plan containing only graphic marks. 

Example of use

Suppose  you  want  to  create  thumbnails  of  the  most
famous "planetary nebulae";

➢ Load the colour HiPS DSS by clicking on the
first bookmark;

➢ In the collection tree, load the
"CDS/Outreach/Nebulae/PN" catalogue using
the "Select" field;

➢ Create thumbnail views via the menu "View =>
Create thumbnail views".  

The thumbnail views are automatically locked in their
central position as indicated by the small padlock at the
bottom left of each thumbnail view (see 5.1.4- locked view).

Tip: Since the thumbnail views are all locked it is easy to delete only the thumbnail views using the
menu "View => Delete all the locked views".

Alternative

It is also possible to use a macro (see 6.1) to generate the thumbnails one by one and save them in
individual files.
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7 Aladin for experts 
In this section we will briefly present different aspects of Aladin, aimed at informed users or data
providers,  who  would  like  to  share  Aladin's  potential  with  their  users.  We  will  discover  the
following:

➢ How to use Aladin in script mode;
➢ Extend Aladin by developing java plugins;
➢ How IDL and Aladin can talk to each other.

7.1 Scripting Aladin 
As an alternative to the graphical interface, Aladin can be controlled with commands. These allow
the  same  operations  to  be  carried  out  as  with  the  mouse,  but  in  an  environment  where  the
"interlocutor" is not necessarily a user in front of his keyboard, but may be another program.

The different applications of script commands

Script commands can be used in different contexts:
➢ As an alternative to using the mouse enter script commands into the console or the control 

field (see above)
➢ As "remote" control by another programme through:

 the standard input. A shell script, or other python/perl/etc scripts will be able to submit 
commands to Aladin.

 the "execCommand(String)" method so that another java application sharing the same 
Java Virtual Machine (JVM) can communicate with Aladin. 
(http://aladin.u-strasbg.fr/java/FAQ.htx#Launch)

➢ To make bookmarks
➢ To write macros (see previous section)

Example script   

Example: Loading an image by URL, adding Simbad, activating the grid and switch-
ing to the "BB" colour table:

get File(http://myServer/myImage.fits)
get Simbad
grid on
cm bb noreverse

List of commands 

The list of commands and a description of each one is available from Aladin’s integrated help suite,
which is  accessible through the menu " Help => Help on script commands " (or Ctrl+F5). This
menu temporarily  transforms the view panel  into a  hypertext allowing you to quickly navigate
through the help. You can also use the script command "help  xxx" where  xxx  is the name of the
command.
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Use of stack planes as "variables".

In the context of scripts, it  is possible to use stack planes as “variables” accessible by name or
position  in  the  stack.  Thus  all  script  commands  generating  a  plane  can  be  prefixed  by
"PlaneLabel = command..." to indicate that the result of the command will be assigned to
the "PlaneLabel" plane (resp. @n where n is the plane number, @1 being the bottom plane of the
stack). If this plane already exists, the previous "value" of this plane will be replaced, otherwise it
will be created on the top of the stack.

Example:  Assigning an DSS/ESO image of M1 the “MyImage” plane:
MyImage = get ESO(DSS1) M1

This  method  is  particularly  practical  and  powerful  when  script  commands  concern  arithmetic
operations on images (additions, subtractions, multiplication, normalisation, convolution...).
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Example: Difference of 2 images in J and F band:
A = get Aladin(J) M1
B = get Aladin(F) M1
Diff = A - B

7.2 Launch of Aladin from the command line 
Like any Java application, Aladin must be run using a Java virtual machine. The command to be
executed in a console follows the following syntax:

java [java_options] -jar Aladin.jar [Aladin_options] ...

Example: java -Xmx2g -jar Aladin.jar theme=classic image.fits

The most  common Java option  is  "-XmxNg" where  "N" is  the  number  of  GB that  the  virtual
machine will use. Depending on your hardware configuration, choose a value from 1 to 2.

The options specific to Aladin are as follows:

Usage: Aladin [options...] [filenames...]
       Aladin -hipsgen ...
       Aladin -mocgen ...
       Aladin -help
       Aladin -version

   Options:
       -help: display this help
       -version: display the Aladin release number
       -local: without Internet test access
       -theme=dark|classic: interface theme
       -location=x,y,w,h: window position & size
       -treewidth=w: default tree panel width (0=closed)
       -screen="full|cinema|preview": starts Aladin in full screen
               cinema mode or in a simple preview window
       -script="cmd1;cmd2...": script commands passed by parameter
       -nogui: no graphical interface (for script mode only)
               => noplugin, nobookmarks, nohub
       -noreleasetest: no Aladin new release test
       -nosamp: no usage of the internal SAMP hub
       -noplugin: no plugin support
       -[no]log: with/without anonymous statistic reports
       -[no]beta: with/without new features in beta test
       -[no]planet: with/without planetary data
       -old: obsoleted facilities re-activated (without any warranty)
       -trace: trace mode for debugging purpose
       -debug: debug mode (very verbose)

       -hipsgen: build HiPS by script (see -hipsgen -h for help)
       -mocgen: build MOC by script (see -mocgen -h for help)

   The files specified in the command line can be :
       - images: FITS (gzipped,bzipped,RICE,MEF,...), HEALPix maps, JPEG,GIF,PNG
       - tables: FITS, XML/VOTable, CSV, TSV, S-extractor, IPAC-TBL, Skycat or ASCII tables
       - properties: propertie record list for populating the data discovery tree
       - graphics: Aladin or IDL or DS9 regions, MOCs
       - directories: HiPS
       - Aladin backup : ".aj" extension
       - Aladin scripts : ".ajs" extension
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7.3 Aladin extension: the "plugins". 
Menu: Tool => Plugins...

Aladin was written in the programming language Java. It thus is possible to develop extensions to
Aladin in order to carry out additional processing,  which are not foreseen in the basic version.
These extensions are called "plugins" and must also be written in Java.

Installing plugins

The installation and management of plugins is done from the "Plugin Manager", which can be
found in the menu "Tool => Plugins =>
Plugin  Manager...".  In  this  window,  you
can  view at  a  glance  all  plugins  already
installed,  and  access  other  plugins
available  on  the  official  Aladin  website
(via the "Load..." button).

For Plugins to be installed, they need to be
compiled (.class or .jar), and located in the
".aladin/Plugins"  directory  in  your  home
directory  ($HOME  on  Unix,  \Users\
yourName on Windows).  After  you have
copied them to this location, you need to
click on the "Re-load" button for them to
be taken into account. It is also possible to
drag  and  drop  them  from  your  working
environment to the "Plugin Manager" list.

Writing a plugin

Writing a Plugin requires some knowledge
of Java. In order to access methods for manipulating the stack, images, and catalogues, the object
class "AladinPlugin" needs to be extended.

Note: A Plugin is a Java extension of Aladin. Thus, plugins have access to internal data structures
with the same speed as Aladin's native code, and don’t need to duplicate them. 

The  technical  documentation  to  create  a  Plugin  is  available  at  the  following  address:
http://aladin.cds.unistra.fr/java/FAQ.htx#plugins. A good way to get started is getting inspired by
the examples on the official Aladin website.

7.4 VOApp & VOObserver interfaces 

Aladin can be "driven" by another Java application via two dedicated Java interfaces called VOApp
and VOObserver. These two programming interfaces are symmetrical and can be implemented in
both applications in order to control the possible interactions. For example, it is possible for one of
the applications to send a table to the other application, and if the user selects a line from this table
in the other application, receive a "callback" specific to the selected line and act accordingly.
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These  interfaces  are  formally  defined  in  the  abstract  classes  "VOApp"  and  "VOObserver"  of
Aladin's cds.tools source package. They can be downloaded individually from the CDS website. 15

 Note:  VOApp  is  the  result  of  a  CDS/VOIndia  collaboration  started  in  2004  to  manage  the
interactions  between  Aladin  and  VOPlot.  Subsequently,  the  IVOA drew  inspiration  from  this
interface to develop the PLASTIC standard, later renamed SAMP and  also supported by Aladin.
You  will  logically  find  the  same  interaction  functions.  However,  you  must  bear  in  mind  that
interactions via VOApp are 100 to 1000 times faster. On the other hand, SAMP extends the field of
use for applications that do not share the same Java virtual machine, or even with a web browser
under http protocol (WebSAMP). These two methods are therefore complementary. It is up to you
to choose which one is the most appropriate according to the context of your development.

VOApp

The VOApp interface has 9 method signatures that you can implement in your application.  As
Aladin implements this interface, these 9 methods are already implemented in Aladin.

The  first  4  methods  manage  the  sending  or  receiving  of  a  catalogue  in  VOTABLE  format,
respectively an image in FITS format:

➢ String putVOTable(VOApp app, InputStream in,String label);
➢ InputStream getVOTable(String dataID);    
➢ String putFITS(InputStream in,String label);    
➢ InputStream getFITS(String dataID);
➢ void showVOTableObject(String oid[]);
➢ void selectVOTableObject(String oid[]);

The  3  other  methods  respectively  manage  the  display  of  the  application,  the  execution  of  a
command specific to the application, and finally the addition of a VOObserver "listener" interacting
with a mouse click (see next paragraph):

➢ void setVisible(boolean flag);
➢ G-string execCommand(G-string cmd);
➢ void addObserver(VOObserver app,int eventMasq);

For  more information:  This  technique is  used by ESO's
"GuideCam" software for the preparation of observations
from European telescopes (the VLT for example), as well
as  by  "APT",  the  NASA  equivalent  for  the  Hubble
telescope and the JWST telescope. 

VOObserver

The  VOObserver  interface  complements  VOApp  in  a  specific  context  of  astronomical  image
manipulation. It offers the possibility of registering your application as a "listener" with a mouse
click in Aladin in order to receive the position and/or value of the corresponding pixel.

It includes only 2 method signatures:
➢ void position(double raJ2000,double deJ2000);
➢ void pixel(double pixValue);

Launch of Aladin

The instantiation of Aladin from your application can be done in the following way:

15   http://aladin.  cds.unistra  .fr/java/VOApp.java  , http://aladin.cds.unistra.fr/java/VOObserver.java
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VOApp aladin = cds.aladin.launch();

Example of use
import cds.tools.*;
public class mytool implements VOObserver {
   public void startAladin() {
      // Instantiate Aladin
      VOApp aladin = cds.aladin.Aladin.launch();
      // Register me for Position and Pixel events
      aladin.addObserver(this,VOApp.POSITION|VOApp.PIXEL);
   }
   // VOObserver callback method for coordinate positions
   public void position(double raJ2000,double deJ2000){
      System.out.println("The current Aladin coordinates are: "+raJ2000+" "+deJ2000);
   }
   // VOObserver callback method for pixel value
   public void pixel(double pixValue) {
      System.out.println("The current Aladin pixel value is: "+pixValue);
   }
}

7.5 IDL / Aladin Interactions 
IDL (Interactive Data Language) is both a language and a calculation engine for image processing.
It is widely used in the astronomical community. A set of IDL functions (".pro" extension file) is
available  at  http://aladin.cds.unistra.fr/java/idl_aladin_interface.tar.gz.  It  allows  to  access  Aladin
from within the IDL environment. You will then be able to exchange images, tables, colour tables,
etc.

For  more  information  on  using  the  Aladin  Library  for  IDL,  please  refer  to  the  FAQ  at
http://aladin.cds.unistra.fr/java/FAQ.htx#IDL

100

http://aladin.cds.unistra.fr/java/FAQ.htx#IDL
http://aladin.cds.unistra.fr/java/idl_aladin_interface.tar.gz


8 Good to know 

Aladin, through its successive versions, is more than 20 years old... it's already a good vintage. You
will find a lot of technical and practical information in the FAQ available at the following address:
http://aladin.cds.unistra.fr/java/FAQ.htx. This document is continuously updated with new versions,
so do not hesitate to take a look at it from time to time to spot new features. There are also a few
"online tutorials", i.e. practical works that allow you to experiment Aladin on astronomical case
studies. You can also watch videos of presentations. These supports are provided either by the CDS
http://aladin.cds.unistra.fr/AladinDesktop/#Documentation or  by  collaborators  or  external  users
reusing Aladin for their own purposes (the web search engines will lead you there quickly).

The following sections present some technical notes that may shed light on Aladin's practice. For
more information, please refer to the FAQ mentioned above.

8.1 The types of data supported 
Aladin supports most of the formats used in astronomy, whether for images, catalogues or data 
"groupings". In addition, it takes into account the most widespread compression algorithms.

Format Type of data Logo Comments
FITS Image [+ WCS]]. No size limit

JPEG 
Colour image [+WCS] 
[+WCS

< 100 Megapixels 16

GIF Colour image

PNG 
Colour image [+WCS] 
[+WCS

HCOMP FITS image compression Applicable to FITS images only
FITS- RGB Image [+WCS]].
FITS-CUBE <1024x512x512
FITS-RICE FITS image compression Applicable to FITS images only
FITS-GZIP FITS image compression Applicable to FITS images only

HiPS image Progressive image survey
Pre-standards and IVOA standard 
(FITS,JPEG,PNG tile support)

PDS Planetary image
Including header and without com-
pression

ASTRORES Catalogue
Predecessor of VOTable, (suppor-
ted for compatibility)

VOTABLE Catalogue
Standard IVOA totally supported 
(base64, BINARY2, FITS, …)
<1 million sources

TBL Catalogue
Format IPAC 
<1 million sources

HiPS catalogue
Progressive catalogue sur-
vey

IVOA standard (TSV tile)

16 Based on a machine with 1Gigabyte of RAM
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FITS-ST Catalogue
FITS table in ASCII
<1 million sources

FITS-SB Catalogue
FITS table in binary
<1 million sources

TSV Catalogue
"Tab separated value"
<1 million sources

CSV Catalogue
"Character separated value" (clas-
sic spreadsheets)
<1 million sources

BSV Catalogue
"Blank separated value"
<1 million sources

SEXTRACTOR Catalogue Default format of S-extractor

HiPS cube Cube progressive survey
Pre-standards and IVOA standard 
(FITS,JPEG,PNG tiles)

MOC 1.0 to  2.1 Coverage (space & time) IVOA standard + JSON support

HEALPix map Celestial map
FITS MFITS dedicated to 
HEALPix maps (RING & NES-
TED support)

MultiOrder skymap Probability map
FITS MFITS dedicated to probab-
ility map (VIRGO/LIGO)

MEF Multiple data FITS multiple extensions
AJ Aladin Stack Stack backup
AJS Script Aladin Script command file

FoV Field of view
Description of instrumental fields 
of view (note IVOA)

DS9 regions Graphic overloads Graphic overloads at DS9
IDL regions Graphic overloads Graphic overloads at IDL

IDHA List of images
SIA alternative, (supported for 
compatibility)

SIA, SIA2 Image list [+WCS]. Standard IVOA
SSA Spectrum list Standard IVOA
TAP, ObsTAP, 
EpnTAP

Result query VO database
IVOA standards (based on VOT-
able)

Datalink List of links
IVOA standards (based on VOT-
able)

GLU List of server descriptions CDS format

properties
List of collection descrip-
tions

HiPS format extension properties

GZIP Compression Applicable to all other formats

Aladin automatically recognises the nature of the data based on the content: the extension of the file
name or the presence of a "Content-type" for an http stream does not affect the recognition of the
file.

Exception: The AJS format (Aladin script) is an exception because its nature cannot be recognised
automatically without risk of confusion. To remove the ambiguity, Aladin will use the ".ajs" file
extension and/or the presence of the following comment on the first line: " #AJS ".
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8.2 FITS standard and astrometric calibration 
For astrometric calibration, Aladin follows the official FITS standard: the first pixel at the bottom 
left is numbered (1,1) and the corresponding celestial position is centred on the pixel. Concretely, 
the coordinate at the bottom left of the first pixel is therefore (0.5,0.5).

Note: IDL does not follow the official FITS standard, the bottom left coordinate of the first pixel is 
(0.0).

Aladin recognises several calibration methods: standard WCS, old DSS1 method, ... as well as most
common projections.

8.3 Performance and technical constraints 
Aladin's development follows two rules:

1. Ensure the best possible compatibility with existing hardware and operating systems;
2. Offer the best possible performance in this context.

To meet these two constraints, Aladin makes the best use of the "Java" programming language.
Java"  applications  require  the  presence  of  a  "Java  engine"  installed  on  your  computer.  Most
operating  systems already have  a  java engine installed by default.  If  this  is  not  the case,  it  is
possible to install it free of charge from http://www.java.com/download.

A counter at the bottom right of the window indicates the amount of memory used by Aladin. By
holding the mouse over this counter,  a window  displays this  value and indicates the maximum
amount of memory that can be used. This limit depends on how the java machine was initialized
when Aladin was started. To increase this value please refer to the corresponding section in the FAQ
(  http://aladin.cds.unistra.fr/java/FAQ.htx#huge  ).

8.3.1 Image management 
Aladin knows how to manage any image size. Depending on your hardware configuration and the
memory allocated to the Java virtual machine, Aladin will be able to choose different more or less
fast strategies:

➢ For images of a few megabytes, the image is fully loaded into memory;
➢ For images of a few hundred megabytes, Aladin will  use disk space to save RAM. The

impact on the fluidity of manipulation is very light;
➢ For images of several gigabytes, Aladin will implement a two-step access: a first immediate

display  in  low resolution,  then  when the  zoom factor  is  compatible  with  your  memory
capacity, a second display in high resolution for the visible portion of the image. The method
for reading the low-resolution image has been optimised to limit disk accesses, making it
possible to obtain a first view in a few seconds, whatever the size of the image. This two-
level resolution strategy is more constraining (waiting time to load high-resolution pixels
when moving) but allows to manipulate any image size as long as it can be stored on a hard
disk.

➢ For progressive surveys (HiPS), Aladin loads only the tiles required according to the field of
view. These tiles are saved in an internal cache ($HOME/.aladin/Cache/HPX) so that they
can be quickly reloaded if necessary. The tile display is a compromise between drawing
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speed and distortion limitation. The principle is based on cutting each tile to be drawn in the
current  projection  into  as  many  sub-elements  as  necessary  to  avoid  the  shearing
phenomenon  that  can  occur  if  the  tile  is  particularly  stretched  (drawn  by  bilinear
approximation). Although the progressive survey is displayed in real pixel values, Aladin
does not load these into RAM, but works on an internal copy of each tile reduced to 256
levels. If necessary, he will look for the pixel value under the mouse directly in the disk
cache. A change in the range of pixel values will result in a complete reload from the cache
of the tiles being viewed. 

8.3.2 Catalogue management 
The handling of the classic catalogues is done by a full load in RAM. It  is necessary to count
approximately 300 bytes per source, which gives a limit of around 1.5 million objects that can be
manipulated with a computer with 1 Gigabyte of RAM. In practice, the limit is rather around 1
million objects in order to leave enough RAM for images and applications.
On the other hand, in the case of a HiPS catalogue, the impact on the RAM memory is not very
significant since Aladin will only view tiles in the current field and at the current resolution. As with
HiPS images, Aladin will keep the tiles already loaded in an internal cache so that they can be
reloaded quickly if necessary.

8.3.3 Filtering collections via the MocServer 
Aladin, from version 10 onwards, offers integrated access to a very large number of data collections
from the CDS and servers  compatible  with Virtual  Observatory protocols.  This  functionality  is
notably illustrated by the collections tree and the associated tools (selection, filtering, etc.). 
The library  used by Aladin to  access,  store  and manipulate  the properties  and MOCs of  these
collections was developed by the CDS. It is implemented, firstly, on a remote server managed by
the  CDS  called  MocServer  (  http://alasky.cds.unistra.fr/MocServer/query  ).  This  server  supports
spatial filtering based on MOCs. These represent a volume to large (several GB of metadata) to be
loaded on the Aladin client. On the other hand, all the properties of the collections represent only a
small volume of information (a few MB). Thus this same library is also implemented in the Aladin
client, which is responsible for filtering properties. These two simultaneous implementations are
transparent for the user (as long as he has internet access). It should be noted that at start-up, Aladin
will synchronise the properties it has with those of the MocServer. These are kept in the local cache
($HOME/.aladin/Cache) in the form of a single file "Multiprop.bin".

104

http://alasky.cds.unistra.fr/MocServer/query
http://alasky.u-strasbg.fr/MocServer/query


9 Keyboard shortcuts 

Access to data collections

Images Ctrl+I
Data bases Ctrl+D
Catalogues and tables Ctrl+T
Search for a collection Ctrl+E
Access to local files Ctrl+O
Server Selector Ctrl+L

View manipulation

Zoom in F2 or mouse wheel
Zoom out F3 or mouse wheel
Pointed zoom F4
Slide/move the view Alt+Z
Next image Tab
1 view Shift+F1
4 views Shift+F2
9 views Shift+F3
16 views Shift+F4
Generation of 1 view per image F9
Copy crosshair position Ctrl+W
Standardize the scale Alt+S
Standardize the scale and the orientation Alt+Q
North up Alt+X

Tools

Print Ctrl+P
Activate the magnifying glass Ctrl+G
Activate the coordinate grid Alt+G
Activate the HEALPix grid Alt+W
Activate the information about the imageAlt+O
Constellation display Alt+C
Distance measurement Alt+D

Handling of plans

Properties Alt+Entry
Display FITS header Alt+H

Handling of sources

Select all sources Ctrl+A
Deselection Ctrl+U
Search by expressions Ctrl+F

Windows

New Aladin window Alt+N
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Open the pixel control Ctrl+M
Backup window Ctrl+S
History window Ctrl+H
Control Console F5
Full screen F11
Single Window View F12
End full screen/single window Escape

Others

Copy Ctrl+C
Paste Ctrl+V
Save Crel+S
Delete selection Suppr
Delete all Shift+Sup
Help of the script commands Ctrl+F5
Guided tour F1
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Glossary
ADQL Language dedicated to the interrogation of astronomical databases, derived from SQL. 

IVOA standard http://www.ivoa.net/documents/latest/ADQL.html (see TAP).
AJ Aladin's dedicated file format for stack backup.
AITOFF A geometric projection representing the entire sphere as a flattened ellipse.
ASTRORES Predecessor of VOTable (see below).
B1950 Equatorial space reference system FK4, equinox 1950.
BITPIX Coding specific to the FITS format. Defines how a pixel value is stored (see below) by 

specifying the number of binary elements (bits) and the representation of the value 
(integer or real).

BSCALE The multiplicative factor specific to the FITS format allowing the conversion of a pixel 
value stored in a FITS file into its physical equivalent value.

BZERO The constant specific to the FITS format allowing the conversion of a pixel value stored
in a FITS file into its physical equivalent value.

Cache A technique for storing retrieved data on the local disk to prevent it from being reloaded
later.

CADC Canadian Astronomy Data Centre. Associated database.
CASSIS Software for the manipulation of astronomical spectra. Developed by the Institut de 

Recherche en Astrophysique et Planétologie.
CDS Centre de Données astronomiques de Strasbourg.
(S)CS (Simple Cone Search) Protocol for accessing a list of astronomical sources located in a 

circle on the celestial sphere. IVOA standard 
http://www.ivoa.net/documents/latest/ConeSearch.html  

DSS (Digitized Sky Survey) Historical reference celestial survey, digitised from collections of
photo plates from Schmidt telescopes.

DS9 FITS astronomical image viewing and manipulation software. Developed by the 
Smithsonian Astrophysical Observatory.

ECL Ecliptic space reference frame.
ESAC (European Space Astronomy Centre) Satellite Data Centre of the European Space 

Agency (ESA).
ESO (European Organisation for Astronomical Research in the Southern Hemisphere) 

Intergovernmental Organisation for Astronomy in Europe.
FITS (Flexible Image Transfert Support) File format dedicated to the storage of images or 

astronomical tables. 
FK4 Equatorial space reference frame. Precursor to FK5 (see B1950)
FK5 Equatorial space reference frame. Precursor to ICRS (see J2000)
Gaia European astrometric satellite. Related data.
GAL Galactic space reference frame.
GZIP Generic, lossless file compression format.
HCOMP A lossy image compression format.
HDR (High Dynamic Resolution) Aladin display mode for viewing astronomical images. 

Takes into account the full range of pixel values.
HEASARC (High Energy Astrophysics Science Archive Research Center) NASA High Energy Data

Centre (see SkyView).
HEALPix System of hierarchical partitioning and indexing of the sphere into cells of equal area. 

Particularly used in progressive surveys (HiPS) and coverages (MOC).
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HiPS (Hierarchical Progressive Survey) Infrastructure for storing and describing a collection
of data located on the sphere (image, cube or catalogue), allowing hierarchical access 
by HEALPix tiling. IVOA standard: http://ivoa.net/documents/HiPS 

ICRS (International Celestial Reference System) Equatorial space reference frame commonly 
used since the Hipparcos mission (1997). Allows location at the millisecond of arc.

IDL Commercial software and associated language for scientific data manipulation.
J2000 Equatorial space reference frame. FK5 equinox 2000 system.
Java Programming language, notably used to write Aladin (see JVM).
JRE See JVM.
JVM (Java Virtual Machine) Software environment allowing the execution of a program 

written in the Java language such as Aladin.
IVOA (International Virtual Observatory Alliance) International organisation whose main 

motivation is the production of interoperability standards for astronomical data.
JAXA (Japan Aerospace Exploration Agency) Japan Aerospace Exploration Agency.
JPEG Image format, general use, lossy compressed, without transparency management.
MAST (Mikulski Archive for Space Telescopes) NASA archive of astronomical data.
MOC (Multi-Order Coverage map) Data format and associated file. Describes spatial, 

temporal, or mixed coverage. Often used to describe the coverage of a data collection. 
MOC is an IVOA standard : http://ivoa.net/documents/MOC 

MocServer CDS server. Directory service of spatially and temporally indexed collections.
NASA (National Aeronautics and Space Administration) Governmental organisation in charge 

of US space programmes.
NED (NASA/IPAC Extragalactic Database) NASA database of astronomical objects. 

Worldwide reference.
OV (Observatoire Virtuel)  see IVOA.
Pixel The smallest element of an image, usually square, encoding the colour or measurement 

level corresponding to its location.
PMRA,PMDEC Values characterising the proper motion of an astronomical object on the 

celestial sphere. Variations in RA and DEC.
PNG A general-purpose, lossless compressed image format that supports a transparency 

channel.
RA (Right Ascension) The first component of an astronomical coordinate corresponding to 

the longitude in an equatorial reference frame. It is expressed in decimal or sexagesimal 
degrees (see DEC).

RICE Lossless FITS image compression format.
SAMP (Simple Application Message Protocol) Protocol governing interactions between 2 or 

more compatible applications. IVOA standard : http://ivoa.net/documents/SAMP
Sesame CDS service and server. Dedicated to the resolution of astronomical object names in 

celestial coordinates.
Sexagisimal Representation of spherical coordinates as two triplets (hours, minutes, seconds) and 

(degrees, minutes, seconds).
SIA (Simple Image Access) Protocol for accessing a list of images. IVOA standard 

http://ivoa.net/documents/SIA 
Simbad CDS service and database. Dedicated to astronomical objects studied in the scientific 

literature. Worldwide reference (see Sesame).
SkyView HEASARC's image generation service.
SDSS (Sloan Digital Sky Survey) Near-infrared astronomical survey.
SSA (Simple Spectra Access) Protocol for accessing a list of spectra. IVOA standard 

http://ivoa.net/documents/SSA 
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TAP (Table Access Protocol) Protocol for querying a database. IVOA standard 
http://ivoa.net/documents/TAP 

TOPcat Reference software for the manipulation of astronomical tables. University of Bristol.
TSV (Tab Separated Value) ASCII file format dedicated to tables whose elements are 

separated by a tab.
UCD (Unified Content Descriptor) Physical characteristic. A keyword from a list of terms 

covering all physical quantities used in astronomical catalogues. Generally used to 
characterise a column in an astronomical table. IVOA standard : 
http://www.ivoa.net/documents/latest/UCDlist.html 

VizieR CDS service and server. Database of astronomical catalogues. World reference.
VO (Virtual Observatory) see IVOA.
VOApp Java interface allowing to interact programmatically with Aladin.
VOTable File format. Dedicated to the storage and transfer of data tables and associated metadata 

(column names, units, UCDs, links, ...) encoded in XML form. IVOA standard : 
http://ivoa.net/documents/VOTable.

WCS (World Coordinate System) Coding mechanism for the function of converting image 
X,Y coordinates to their long,lat correspondence on the celestial sphere. Usually stored 
in the header of a FITS image.
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